Diatone Tyrant S 215 replacing FC


#21

Thanks, I solved it with the video Tim sent me, but I´m not able to get above 0.0 volts so I get an Low Voltage alarm from the OSD(not the FC) even if I tune the parameters in MWOSD. I see in the MW OSD that there are several OSD firmwares to install, I installed the one for MinimOSD as there wasn´t any for my Diatone SP3 OSD, is this right?

Jorn


#22

Hi Jorn,

Glad to see that you solved the issue. My I ask what it was that was preventing your quad from arming?

About the OSD. If using the MinimOSD was the wrong way to do it, I would have thought that it wouldn’t display any data, not just the voltage, but I may be wrong. I found this video which may help you:

Good luck,
Tim


#23

Hi Tim
It was a combination with the copter was not level, and endpoints on the Taranis. I just read this in a thread at www.oscarliang.com
"Also i find it a bummer that the 2-4s voltage input cannot be used to measure voltage. You have to use everything from the FC, except RSSI which the VTX can inject into the OSD."

The problem is that I don´t find a way to measure the voltage from the FC to the OSD. It might be through the IO_1 pin 5 and 6, as VBAT is connected. There might be somethin in the config for this, but i can´t find it.

Jorn


#24

Hi Jorn,

My Minim OSD Micro gets VFAS from the Flight controller through the softer serial 1 (pins 5 and 6 on IO_1) and that works perfectly. It might be worth trying to use these pins if you aren’t already.

Hope this works,
Tim


#25

Hi Tim
I already use these pins. I can of course try to swap them…

When I tell MWOSD to sence power from the FC, i don´t get any amp or mah displayed on my monitor/goggles.
This all thing is kind of strange. I´ll try to draw a new connection diagram this weekend.

Jorn


#26

Hi Jorn,

That is very strange. Maybe one of the DNUTS team might know what could cause this issue.

Hopefully we can get to the bottom of it.

Tim


#27

Do you have everything else working on your OSD? So its just the Amp/MaH not dispalying at all? But yeah let us see your connection diagram so we can try try to help :slight_smile:


#28

Hi all
I moved the connections from IO_1 on th FC to Serial1(GND; Rx, Tx) which are shared with the USB port, and now it all works. I can now see Voltage, amp, and mah, and even signal strength from my Taranis/Tx.

Now I just have to remove the cable when using the USB port, but it would have been nice to get it to work as Tim suggested. Right now I´m happy to see that it work, so thanks Tim for all your good help.

Jorn


#29

By the way, I´ve bought a FLying Wing, a Sonicmodell AR Wing 900mm which I will need a FC for and I thought about a F4 FC which I can use Pixhawk Arduplane FW on. Any suggestions?

Jorn


#30

Hi Jorn,

I’m glad that you have got it functioning properly even if you do have to remove the cable. Apologies that it took so long to sort the problem.

I don’t know too much about flight controllers for flying wings but I would recommend the Omnibus F4 V5.1. It’s got 4 UARTs, a built in OSD and an SD card slot for the black box data. And there is a fantastic set up guide by @unmannedtech:

https://blog.dronetrest.com/omnibus-f4-flight-controller-guide/

Good luck with it!

Tim


#31

HI TIm
It´s not your fault that it took so long. I´ve been flying it this weekend and everything seems to be ok until I wanted to connect it to the USB port. I get an error stating the board can´t be recognized. I´ve tried to do all unbrick things mentioned on dronetrest.com

Here


Here

and here

And nothing works

This is my first F3 board. I´m used to APM, Pixhawk, Vector, but not this FC´c. I´ve heard about this FC´s and that they are easy to brick, and also might be bricked when arriving, so right now I don´t trust this and might just put on a Mini Pix on the Tyrant S 215, or go back to flying wings again, but that´s not your problem.

I´ve been to your website and some others to see if I can buy another one of this FC´s, but everyone is Out of Stock.

Jorn


#32

Hi Jorn,

I haven’t experienced a bricked FC before. It must be to do with the OSD connection.

Does your computer register that the flight controller is connected in the device management list? Depending on what it displays the device as could indicate the problem.

If you nolonger trust this flight controller I don’t blame you as you haven’t had a brilliant experience with it. I purchased mine from here:

If you do decide to order it, I would choose priority direct mail as this is the fastest method and it usually costs <£3 for it.

Tim


#33

Me neither Tim.
It was after connecting to the UART1 it stoped working. The FC works, but there is no way it will appear on my PC or Mac. The OSD has no problem at all connecting.

I also bought this FC from banggood.com. Shipping from China to Norway is 16 pounds so I´ll go for UK shipping for the two i just bought. I should have them here in about 7 days. One of them have to work, don´t you think?

Jorn


#34

is your connection problem…

cause USB uses UART1 for the connection to the computer

and if your’ve configured it to be used as something else?

The only way I know to recover the FC is to do a reflash… but that will wipe everything first.
So unless you have a backup it may put you back a step or two.


#35

Hi
Yes, I know that, and I did remove the UART1 cables before connecting, but there are only errors from Windows 10 when connecting.

This is the error(translated from Norwegian)

"The last USB device you connected this machine had an error. Windows do not recognize it"
And then there is no need to install new drivers as Windows does not recognize the board anymore to install the reght driver.

When I connect my OSD, there is no problem at all.

Jorn


#36

Windows 10

I just tried to use my windows 10 laptop on a working FC and it wouldn’t connect…

Try reinstall the STM32 Virtual COM Port Driver…
http://www.st.com/content/st_com/en/products/development-tools/software-development-tools/stm32-software-development-tools/stm32-utilities/stsw-stm32102.html

and reboot… thats what worked for me.


#37

Hi
Right now I´m cloning my HD to a new SSD so I will try that later even if i´ve tried it before. I reinstalled Windows 10 before i cloned the disk so it might help.

Jorn


#38

Let us know how you get on… but I am assuming that when you plug in the FC, it has some LED’s showing on it? Because if not then the device is probably dead… but if you have LED’s then its likely to be a driver issue, or a firmware issue.

Another thing worth doing is removing everything else from the FC, in case you soldered something wrong, or connected something wrong to it that is preventing it from working normally.


#39

I will do Alex
Everything is disconnected and the board is removed from the drone, and the blue LED are lit while the red one is blinking when connecting the USB cable. By the way, i´m able to fly the drone, but not connect to it. And the OSD is also working. Thats a bit strange.

I´ll be testing more tomorrow.

Thanks for all your help guys.

Jorn


#40

Hi All
This is what i´ve done today.

  1. Tried to set Windows to developermode, no luck in getting any drivers working.
  2. tested my Pixhawk with Mission Planner and there seems to be the same problem for the Pixhawk to.
  3. Did a clean install og Windows 10 with all updates.
  4. Installed Mission Planner as this also installs the right drivers for the PH. All working well with PH and MP,puh:-)
  5. Installed CleanFlight Configurator(not the Chrome version)
  6. Tested the Fury F3 FC which came with Diatone Tyrant S 215 2017. Installs the silabs CP2102 driver when windows ask for it. All seems to work, but I´m not able to connect to Cleanflight.
  7. Holding the BOOT button down and conencting to Cleanflight to install Version 2.3.2 and it works.
  8. After beign able to install new firmware i´m eager to test to see if it still works with Cleanflight, but it does not. It says Opening device and closing device, so no configuration yet.
  9. Trying to connect the SPRACING F3 FC and get the same message as always. Windows does not recognize the FC and are thereby not able to install any DFU and/or STM32 Bootloader.

Right now it works with my old FC´s(Pixhawk and Vector) and I will be flying them this weekend and have now done the hammerdance on the SPRACING F3 FC. I just got the words from Banggood that they have sent me a new FC from the UK. It´ll be here in 7 days time so then I will see if I´m able to connect anything to Cleanflight or iNav to get my Tyrant to fly again.

I can´t see any reason for this not to work, and I can´t see any reason for one FC suddenly not working just by connecting three cable to UART1 but disconnecting them before using the USB port. The worst thing is that I´m not able to put back the original FC to as I´m not able to configure it in Cleanflight.

By the way, the STM32 drivers on the STM site are not for Windows 10 and it is not possible to install them as windows is said to have them in it´s installer package. I was not able to install them from the links provided earlier.

Jorn