Diatone Tyrant S 215 replacing FC


#1

Hi. I have a Tyrant S 215 2017 which i want to replace the FC with an SPRacing F3 Deluxe FC with INav and put on a GPS. I´m also replacing the Diatone SP2 with a SP3 with OSD.
I´ve figured out the motors and the SBUS connection but are unsure with the Buzzer and the two VCC/GND ports on the right hand side of the motor connector and where to connect them to the SPF3 board.

Regards
Jorn


#2

Hi John,

Do you have any pictures of your current setup and the spracing f3 delux. I have wired up an SPF3 acro and just want to make sure that yours has a similar pinout.

Tim


#3

Hi Tim
Heres a picture of the frame with the SP3 OSD installed and the three ports in question is marked in red and with the SPRacing F3 board on the right. Because of the size of the SPRF3 board i have to install it on the top of the frame.

Jorn


#4

I know on the SPracing F3, the buzzer can be wired to the two pads on the left hand side of the board. The SPracing F3 also has a voltage meter built in and for this you can wire your VCC to the connector on the opposite side to the buzzer.

I hope this helps,

Tim


#5

Thanks Tim. I’ll try it out tomorrow.

Jorn


#6

Hi
I´ve been drawing a connection diagram for this and that arrised a few questions. I have SBUS on IO_2 connector(7) and it seems like port 3 uses Rx from UART3.
I also want to connect OSD to the FC to see data from the board, but I can´t seem to find anywhere to connect it if i cant use UART3, Rx port for this?
If I understand the FC connection diagram right I can´t use the IO_1(6) connector for this either, or can I.

Sorry to answer all this questions, but there are not many people that have connected this together and documented it out there :slight_smile: I can fly this thing, and are learning the electronic part as I go on here.

Jorn


#7

Hi Jorn,

That is a very usefull list and it would have been very hard when building my quad.

About the wiring, I have my SBUS wired to the IO_2 connector with GND on pin 1, positive on pin 2 and SBUS on pin 3 (serial RX is set on UART 3 in betaflight).

I have my telemetry wired to the TX pin on UART 2 and my OSD is on IO_1 with the RX on pin 5 and TX on pin 6.

For this to work you must have soft serial enabled in betaflight and enable telemetry on soft serial 1 so that the OSD can display it. You will then be left with another soft serial port which are pins 7 and 8 (TX and RX respectively) for another use.

This video gives a good explaination of the soft serial set up:

I hope this helps,
Tim


#8

Thanks a lot Tim!
If I understand this right… I´m setting the FC up with INav with a GPS on UART2. Can I then use port 7 or 8 on IO_1 or IO_2 for Telemetry with soft serial enabled?

Jorn


#9

Hi Jorn,

Your GPS seems correct but I think you need to connect the telemetry to the TX pin (pin 8) on IO_1. This should work for smartport telemetry (frsky). OSDs can vary I believe.

Tim


#10

Hi Tim
I´ve now set up the Tyrans S 215 and all is working but Modes and failsafe in iNav, but i´ll take that in the morning before flying. I connected everything up and it all worked right away thanks to your help.

Thanks a lot.

It all helped a lot.
Jorn


#11

Hi Jorn,

Excellent. I hope flying goes well.

Glad that I could help.

Tim


#12

Hi again Tim
I´m having a strange problem, and that is on the OSD. It flashes low voltages on the screen and I can´t arm the drone. I´ve tried to disconnect cable from IO_1, and even the FC so I only see data from the OSD. No matter what I disconnect, it´s still there and the drone wont arm. I can configure the FC with no problems, and the OSD to. I´m sure it´s a tiny thing, but I just can´t see it now. Do you have any idea what this can be? I´m connecting power for the FC through port 1 with ESC 1.


#13

Hi Jorn,

Have you powered the board with 5v regulated power from the PDB? I have connected this to an unused positive and ground motor pad. If you haven’t done this then it may explain why the quad won’t arm.
For the OSD, is it defiantly configured for the same lipo that you are using? It could be saying low bolts because it is configured to display low volts for a 4s and you may be using a 3s which at full capacity is below the low voltage threshold for a 4s.

Also, have you configured the FC so that you get telemetry to you transmitter? If so, do you telemetry when the battery is connected?

Tim


#14

Hei Tim
I´m powering the FC through the same 5V and GND as the old Diatone Fury F3 board was powered through as shown in the picture.
I´m not sure what you mean by an unused positive and ground motor pad? Do you mean connecting to a 5V on the solder point for the LEDs and the GND to the ground on the ESC?

The MW OSD autodetects the battery. I only use 4S 1550mah Gens Ace batteries for this quad. I´ve also tried to connect a 3S 10000 mah battery. The strange thing is that I can see the volt and the current of the battery in the Configuration menu in iNav when enabling Battery voltage monitoring and Battery current monotoring, but it says 0.0volt in the OSD, but shows amp and mah+ that is different from whats in iNav. Is that an indication of something wrong?

I´ve figured out that my Frsky XM+ doesn´t have Telemetry, so I really dont need it now.

Jorn


#15

Hi Jorn,

I power my FC like the image show below.

In betaflight or whichever configurator you are using, have you enabled MSP and selected to correct bit rate for your OSD on the correct softserial port? I thought that I enabled telemetry on mine but it is the MSP that needs to be enabled.

It very unusual that your OSD is getting amps and battery consumption but not voltage. The only thing I can think would cause that is that the OSD might be taking voltage from another source and not the flight controller. I would just double check this in the config. The amps and consumption could be different since they may be calibrated differently. My OSD displays slightly different values than my QX7.

Are you sure that the transmitter is binding with the quad? If the Buzzer is configurated to a switch on the transmitter, does it come on when the correct switch is activated. This could indicate if the arming problem is a connection issue.

I hope this helps

Tim


#16

Hi TIm
And thanks for helping me out. This is what i´ve done today.

  1. Reset the FC to default and disconnected all but Motors, Beeper, and power to port 6 +/- as you have done.
  2. Recalibrated ESC´s in iNav and tested all motors and directions and all seem well.
  3. Changed and bound an FrSky X8R Rx which are woking in a plane I have. I also tried the XM+ Rx and this plane, and it works.
  4. In the receiver menu in iNav I see AETR and all switches and they are working in here.
  5. Connected the battery and it should be working, but it does not. All I get from the FC is a blinking red light and a very short beep. I also have a steady blue light on the FC. I can´t find any information on what the leds mean blinking or not, blue or red.
  6. I still get power from the PDB as I don´t know any other places to get power from on the Tyrant S 215. I will try to roll back to the old FC with the new OSD to see it this still works. If it does, there must be something wrong witht the new FC.

It is about 30+ degrees celsius her this days so we have a hard time doing anything here.

Jorn


#17

Hi Jorn

It seems like it is not an issue with your transmitter then if the switches are working in the configurator.

It is defiantly an issue with the flight controller it would seem.

When you say that you have calibrated your ESCs in iNav, have you checked to make sure that the correct motor protocol is selected? This will depend on the ESCs that you are using but it looks like they are capable of Dshot600 in the picture above.

When you connect a battery to your quad whilst in the configurator, will it allow you to spin up your motors using the slide bars?

Tim


#18

Hi Tim
The motorprotocol is set to the same as in the original FC, Dshot42. I see now that the ESC´s say dshot 300/600, strange then that they use dshot42!?

I don´t remember if it the motors spin up when using the slide bars with the USB connected.

A friend with more patience than me in this warm weather has taken the drone with him to see if he have more luck that me. Then I can go fly my plane :slight_smile:

I´ve bought the Velocidrone to learn drone racing and hope that it will give me som education in drone flying.

Thanks a lot for all your help.

Jorn


#19

Hi Jorn,

I’m sorry that I wasn’t able to find the soloution to your problem. Hopefully your friend will be able to see something we haven’t.

If he does then check out this video:

Joshua Bardwell has some very useful videos that help to solve a lot of problems.

Good luck!
Tim


#20

I agree he does have alot of good videos and hepls alot of us. I also like to think I have some helpful articles :stuck_out_tongue:

I recently wrote one on the exact same topic here: