[Help] SPRacingF3 not showing telemetry in Betaflight - Nor connecting unless I reflash

Hello, So I just got around to building my drone and everything was going well until I got the firmware flashed in betaflight. I can connect to the spf3 from betaflight over usb, however none of the info for the telemetry such as pitch and yaw etc is working and on top of that it won’t register the receiver(FS-ia6b) actions on betaflight even though I binded it to my FrSky. I also want to add im using the IO1 ppm to the ppm connector on the rx if that helps. I’m a complete noob and need some guidance as I would love to get flying soon!

edit: at work rn, will send pics of chips and setup when I get home to help you help me!

Hello there SHFTY sorry to inform you that you have got an old receiver running PPM and IBUS. To enlighten you nowadays SBUS is the modern standard in FPV but we could utilise IBUS. First point you’ve made is that being able to connect to Betaflight. This is good news because you can go to the Configurations Tab and look what receiver you have in your case set its to Serial based rx and set to IBUS. This allows you to see which RC protocol you are running. Second point you’ve made about the receiver not showing input commands in the Receiver Tab this is because the FC can’t recognise the incoming signal from the receiver(FS-ia6b). Lastly, you have said that you connected “IO1 ppm to the ppm connector on the rx” to begin with make sure that turn on Serial RX of UART3 in the Ports Tab.
If I’m not clear enough I have found a link to a youtube channel that you could also watch and I hope that I helped you. Link: https://www.youtube.com/watch?v=Pn8Eo4NS3d8

2 Likes

Alright I’ve had another issue come up in regards to this. I couldn’t connect to the fc from beta flight so I re-flashed the fc then connected right away. however when I go and hit save-reboot to save my config I can no longer connect back to the fc with beta flight unless I re-flash the fc again, but that makes me lose all my configs.

are you unselecting the VCP port ?

cause that its you USB link into the FC.

1 Like

not to my knowledge, I don’t unselect anything I did a quick test, I re-flashed the fc then connected let it sit for 5 minutes and disconnected along with unplugging the wires, put them back in then tried to reconnect on betaflight to no luck as it will try to open port but not connect.

edit: I’m running configurator 10.4.1 with the 4.0.4 version of firmware for fc

Upon reflashing your FC you might want to consider updating your drivers using Zadig and configuring your COM port/s.

1 Like

The drivers seem to be up to date and formatted, I used zadig and moved the cp2102 to winusb v6.1.7, then headed over to the device manager and set the driver to be cp201x and still no luck. It’s odd because I can flash it almost anytime but it will never reconnect without reflashing :face_with_monocle:

flash the FC to betaflight then try and run the ImpluseRC driver fixer

and see what that does for you

1 Like

still no luck, the impulseRC driver fixer can’t find the fc

Edit: photos of setup


Try having a watch of this video and see how you get on.

Hello SHFTY make sure your FC is getting powered using a data cable. If impulse rc driver fixer was ineffective then a manual installation of the driver/com port is required. Firstly go to device manager of your computer then find your FC(“name”) which can easily be found in the Universal Serial Bus controllers. Then right click on the FC and update driver. In this step make sure you select “browse my computer for driver software” then “Let me pick from a list of available drivers on my computer” from there find the STM com port driver then your sorted.

1 Like

Another thing you have to be aware of is that when your flashing you are in DFU mode and if you are connecting in general like connecting to BF to configure, then you are using the COM port mode. Make sure you don’t change the drivers when in DFU because it can mes things up. In you case I suspect that your are mostly likely having COM port problems.

1 Like

the picture of you receiver, it doesent look like the plug is in ch1/ppm. can you confirm it is?

1 Like

do you know you can fit the FC so usb come out the side, just adjust the YAW on config page to -90 or 90 degrees

1 Like

make sure accelrometer is enabled, as if not on the quad pic in betaflight tab wint move as you move quad around

1 Like

@SHFTY when you plug in USB, do you see any LeD on your FC, as in the photo you posted with USB, I could not see the power led, so if your usb was connected to pc then it looks like your board might be dead :frowning:

1 Like

To answer Alex:
When I plug the usb into the FC, the blue led and the red flashing one turn on, unless bootloader is shorted then the red’s off.
Dale:
When I reflash the firmware and connect to the FC I checked to make sure and the accel is enabled and it is, and the quad pic still doesn’t move. And I’m aware that the orientation of the FC doesn’t necessarily matter as you can just reprogram it in betaflight however since the quad pic isn’t showing any movement or calibration per se, I can’t tell which way to adjust the settings to make it right, and even then I have to hit save and reboot which then basically locks me out of the FC and I can no longer re-connect :neutral_face:

edit: I have it plugged into the I-bus to ppm, +, and grnd on the FC, even switching it to the verticle ppm/ch1 doesn’t do anything yet and I can’t try the taer1234 mapping due to the FC locking me out

I’ve also tried multiple USB cables and 2 windows laptops + 1 mac air; all can write the flash to the FC and connect the first time so I don’t think its a usb problem, but quad pic in preview doesn’t move when I move the fc around in any of the cases so far.

could you try a older firmware!

I tried every version I could in betaflight for the SPF3 and none did the trick, coming to terms with the FC is probably defective. Taking the advice and upgrading to a board with sbus and OSD! Appreciate all the response this got as I learned alot!

SHFTY,
Listen, do yourself a favor, Upgrade. The F3 boards are not being much supported anymore. Another thing, ditch the CPPM go with Sbus. I just built a killer long range Quad based on an aftermarket “shell” type frame, and I used an “just so happen to have” FRSKY D4R-II CPPM receiver I had laying around, and am seriously regretting it. In doing this everything is crammed into this thing, and it is a serious wanker to get it apart due to it being held together with screws. For some reason it interferes with the GPS via some sort of bug. I have tried everything. It is a bug. Rather than report it on GitHub, I just replaced the receiver with an Sbus receiver, and problem gone.
Go with a Matek F405 mini. Matek has awesome support, and they answer questions usually within 24 hrs.http://www.mateksys.com/?portfolio=f405-mini