SPR F3 not connecting to computer


#1

I just purchased a spracing F3 flight controller, and it won’t connect to betaflight nor my computer at all. I’ve tried all the drivers said on the betaflight page but none of them made the COM port to show up. ImpulseRC only shows “searching” and Zadig doesn’t show any port. I’ve also tried it on both my desktop and laptop and they both show the same problems. Any idea for a fix?


#2

does the FC light up when you plug it in?

Have you tried different usb cables. some only do power and not data.?


#3

The FC might be flashed with Cleanflight as opposed to Betaflight. This is a distinct possibility with an F3 board.

You could also try a different computer if you have one.


#4

I have a suggestion, usually you would install either cp or stm32 drivers but mostly for f3 boards its cp210x drivers. Install the cp210 driver to your computer and then launch zadig, click options, list all devices the FC should be recognised(it should state its brand or name). You could also do this while your board is in bootloader mode and try installing the new driver