FC not connecting to PC

Hey,
My mamba f405 dji FC is not connecting to betaflight nor my PC. It was working well and good and once i removed the cable without disconnecting my FC from betaflight and later on it isnt connecting to my PC and i dont even get the usb sound when connecting it but my FC led lights up when connecting. I reinstalled all the required drivers and tried impulse RC driver fixer but it keeps showing searching for FC and my FC doesnt shop on zadig. Im new to this hobby and this happened on my first quad. Please help.

hello down this from web, this will fix your driver fc …ImpulseRC_Driver_Fixer

Try a new cable, sometimes they go bad, also the USB connector on the board goes bad also sometimes. If that is the case, there are other ways to open communication to the board, but it’s involved, and you will have to search the forums for clues. Been there and done that.

Easiest thing to do is buy another board if nothing works.
Cheers

I also have a similar problem, - no com ports being made- but I really can’t buy another board, for lots of reasons. My win7 computer is a middle-aged but powerful one, and I can’t replace it either.

I sorta solved the problem by installing win10 on a double boot, but I really hate it-- basically a marketing platform.
How to get my win7 to make com ports for flight controllers??
Using arduplane on a Omnibus F4pro v3