Cant update firmware in boot

Hey guys, I’m trying to update firmware for the first time in my FC F405 Mamba and F40 ESC/ the FC seem to be fine, I can connect to it normally and play with the settings and change, but when I want to update the firmware I click on the boot button, connect the cable, I hear the computer recognizes and I see in the device manager STM Device in DFU Mode and only the red LED is on, but now in the betaflight I dont see the COM, I try anyway to flash it but its writing failed to open serial port.
I tried most of the stuff in this post:https://intofpv.com/t-cant-flash-firmware
but didn’t manage to work it, any help?

if the FC is in DFU mode you should see DFU where com port number normally is when you plug FC in BF.
If not just plug board in BF and go to this page and download and run the impulse driver fixer . https://impulserc.com/pages/downloads
you should now see DFU mode where com port should be.

2 Likes

Thank you very much! that solved the problem quickly.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.