Is my flight controller dead?

So my Mamba F405 Mk2 flight controller won’t connect to betaflight anymore. It was working fine the day before. When it is connected to my pc the flight controller has the correct LEDs lighting up as you would expect but then nothing happens. It’s not even recognized in windows at all, as if it wasn’t plugged in. Tried using the boot button on the flight controller to boot it into DFU mode but still nothing. I have tried dozens of cables, even ones that have worked in the past. I also tried it on my laptop but instead of getting absolutely nothing when plugging it in, I get a windows error saying USB device not recognized, and when looking in device manager I can see the flight controller listed as “Unknown USB Device (Device Descriptor Request Failed)” which leaves me in the same situation as before.

I have tried reinstalling drivers, using the Zadig tool and Impulse RC (both of which won’t work because the flight controller isn’t detected by the computer at all). Tried hooking up the battery to the quad first and then connecting it to my PC with the same result. I’ve used a multitude of USB Cables and different computers and USB ports. The quad flies fine, and everything works, but I just can’t connect it to betaflight to configure it!

Please if someone could help me I would be most grateful!

sounds like you have tried everything, if i ever have a problem “Impulse RC” normally sorts it. if windows doesn’t do the chime when plugged in i would suspect the usb connector on the FC as gone faulty.
sorry its no help but it would appear you have tried the lot.

That’s what I would think too, but I don’t believe it. I’ve looked at the contact pads on the micro USB connector and they look fine, the traces on the board also look fine, and obviously, it’s getting power because the led’s light up. So it has to be something else.

I use do debug usb connecting issues and check for devices/drivers. See if you can find something out that way. Try also pluging and unpluging it while usbdeview is running and see if it’s recognised by windows at all.