A newbie question when soldered receiver


#1

Hi,

Well this is the first time I’ve soldered something to the ECU, or is it FC? so forgive a newbie question here, now before you say to look it up, I did this and all I find it stuff relating to computer issues and not quadcopter… But yeah, as I was saying; after a receiver is soldered to the ECU/FC, is it a common firmware/other issue for the ECU/receiver to beep 6 times, I know when you power a quadcopter up it’s supposed to be 3 quick and then 2 short indicating that it’s working, but after trying to power this one up, it does 2 lots of 3 short beeps and sometimes the motors would spin and stop quickly.

ECU/FC is Mamba F405 Mini
FrSky XM+ receiver

Any help is appreciated!


#2

Hey daedalus,

First off, all newbies welcome so no need to apologise there, we’re all learning :wink:
Yes so it is the FC you should have wired your receiver to. Is it only since wiring the receiver on that the quad is doing this sequence of beeps?
It would be worth configuring the FC in Betaflight then seeing if this corrects it. You want to set the ESC protocol up. Ideally set it to DSHOT600 and then try the boot sequence again and let us know if that has corrected it.
Good luck buddy!


#3

Hi mate, nah Windows doesn’t seem to recognize the quad for some reason after wiring, hypothetically speaking if the FC was knacked, would I have to replace the board where the motors hook up to + the FC? This was another thing I forgot to ask xD As the ones I find online come with the board for the motor, ECU I guess it’s called? xD


#4

Does the FC light up when you plug it into the computer? If not then the FC might be dead…
If it does light up, it means either your cable that you are using is not a data cable or you need to install some drivers.
Check the cable first. Is it one you use to transfer files to a phone and/or tablet device?


#5

Hi mate, yeah the FC lights up, solid green light with sometimes red flashing, I don’t believe it to be a driver fault, as I can connect to my other quad with no problems, just says Windows doesn’t recognise the usb, whereas if I connected my other quad up, it’d work.


#6

Something to try then is plugging in and using the ImpulseRC driver fixer. This thing has corrected problems for me after I’ve installed the drivers and it’s still not worked.


#7

I did have a look at this yesterday, but thanks I will definitely have another look at this when I get back from work.

I’ll keep you updated.


#8

Hi, So further update - The fixer doesn’t seem to pick up the FC, should it only be relying on the FC itself, or depending if other parts are working too, I.E. ESC/receiver?


#9

It might help if you can send a photo of how your receiver is soldered just incase that has caused something to break. But assuming not, when you plug in the USB cable do you see any LED lights on your FC?


#10

Hi Alex,

I’m just going on the assumption that the FC is dead, it does light up however, just Windows says the device is malfunctioning.