Betaflight receiver issues


#1

Well, I’ve certainly run into an interesting issue…

I recently starting building a new drone (one of the flitetest gremlins) and am having an interesting issue with the receiver. Before I continue, here’s what I’m working with: f3 femto flight controller, frsky xm+ rx, and taranis qx7. All components and transmitter are brand new.
So, when I connect up to betaflight, it recognizes the drone and the gyros work and everything. However, when going to the configuration tab and changing the receiver to a serial receiver (documentation for the fc: http://www.yinyanmodel.com/upload/20161111/20161111094147991.pdf documentation for the rx: https://www.frsky-rc.com/wp-content/uploads/2017/07/Manual/Manual-XM%2B.pdf) and then to SBUS for receiver type and then saving and rebooting, it doesn’t save the receiver type and reverts it to spektrum1024. Additionally, (likely related) when going into the receiver tab, all of the bars read zero even despite changing the high and low ranges.
I’m pretty sure that the receiver isn’t broken as I am able to bind the qx7 to the receiver. Sidebar: when binding, the transmitter asks me if I want to bind channels 1-8 with or without telemetry or channels 9-16 with or without telemetry. None seem to make a difference, just wondering for when I get everything working.

I’ve double checked my soldering and everything seems to be in order.

Any help would be appreciated, I’m still getting into this kind of stuff and would really hate to have something like this hold me back from enjoying the hobby.

Thanks in advance.
Also, I can upload pics if that would be of any help.


#2

So just to comfirm…

You have plugged in the XM+ to UART 3
image

In Betaflight on the Ports page:
You have selected Serial RX on UART 3 and nothing else.
Then clicked “Save and Reboot”

Then on the Configuration page:
Receiver Mode - Serial-based receiver (SPEKSAT, SBUS, SUMD)
Serial Receiver Provider - SBUS
Then clicked “Save and Reboot”


#3

I remember this was a big with some older versions of betaflight. So my suggestion would be to make sure you are using the newest version of betaflight firmware and GUI.

Then if I remember correct you first need to go to the ports tab, turn off serial Rx, save and reboot. Then go to reciever and select ppm. Save and reboot. Then go back to ports enable serial Rx, save and reboot, then select sbus for reciever.

Let me know if that helps


#4

@DoomedFPV Yes, XM+ has been plugged into UART3 (See pic). I made sure the settings you mentioned were selected and hit the save and reboot on both ports and configuration tab and the ports remained unaffected but the receiver reset itself to Spektrum1024. (See pics)

@unmannedtech I’m running Betaflight configurator version 10.2.0 I tried your suggestion as well with the same result as above.

Thank you both for the expedient replies.

Is it possible that I accidentally bricked the receiver?


#5


#6

The fact that the FC is not saving sbus would suggest the issue is with the FC, not the reciever.

My suggestion would to try reflash the firmware again, but when doing so try select the full chipmerase button as then it will clear the eeprom which may fix the issue?


#7

As Alex says
Try reflashing you board.Looking at your screen shots. Your configuration still says your running BF 3.0.1
image


#8

Alright, so I’ve attempted to reflash my board by when I jump the boot pins and attempt to reflash, I’m getting a no response from bootloader error. Any idea why that might be happening?


#9

Try this

  • Unpluging the USB

  • Short the boot pins.

  • Plug back in the USB

  • Then try flashing.

image

Then when it starts… with an erase first. You can release the boot pins.


#10

Still no response. Should I assume that the fc is bricked?


#11

I would say no… cause its working with the configurator.

How are you shorting the two boot pins?


#12

I’ve tried both holding a stripped wire across the pins and soldering the two together


#13

ok.

Try
Going into CLI on the configurator and typing in
BL

and see if that puts you into DFU mode


#14

BL command didn’t work, used command dfu which put betaflight into dfu mode. Attempted to reflash, still no response…


#15

Strange…

DFU does nothing for me.

The BL puts my board into DFU mode as expected. I have to close down BF configurator and re open it. But the I see my board is in DFU mode


#16

image


#17

Ok it could be.
Your board is in DFU mode.
But now you missing drivers.

If you board is in DFU mode… you wont be able to connect to it with BF until you unplug and replug the USB cable.

Try this driver fixer


#18

So I ran that driver fixer and it said that it succeeded. I opened cli again and ran the dfu command and I cannot get the fc to enter dfu mode/ connect to my computer.


#19

Not sure what happened, but it just stared working all of a sudden? I’ll continue through the set-up process and post again if I encounter issues or everything works as expected.


#20

They must have changed the command in different BF Versions.

Good luck