Can't connect to Betaflight unless I disconnect the receiver among other things

I bought a 5" PNF quad and after updating betaflight to 4.1.1, soldering my receiver on and binding it to my Taranis I looked in betaflight to see if the channels were mapped correctly. I could see that they were all jumping around erratically so I created a new model (instead of using the model I copied) and did the binding process again using the battery. I quickly noticed the intermittent beeps but after a minute the motors started going haywire. I unplugged the battery quickly and noticed that the motor wires were hot, now Betaflight won’t connect unless I disconnect the receiver. I don’t want to fry anything so I need to choose my next steps carefully. This is a brand new quad and I’m afraid of cooking it, any guidance from more experienced pilots would be greatly appreciated.

I should mention that the motors only go berserk if the transmitter is powered on and replacing the receiver does not change anything. What am I missing here? I’m eager to fly something bigger than a toothpick but I’m dead in the water…

1st let me say to all that read, if you are new to quads stop upgrading betaflight until you know quad works first as it changes loads of settings.
Right does your quad connect to betaflight if so could you screenshot the setup, ports, config and receiver screen and upload here please, may be able to help with this info.

I’m not completely new to quads, this is my 4th but I see your point. Here are those screenshots:


when you say motors go bezerk do they spin or beep. and if receiver disconnected can you plug battery in ok.

1 Like

They spin jarringly off and on in no particular pattern. When the receiver is disconnected there is no problem with the motors. I also tried a different receiver and got the exact same result.

what receiver you using and r u sure soldered to correct pins

1 Like

I tried the XM+ and the XM Micro both using the provided pins. I connected it like shown in this picture.Wiring

But you have receiver set to Spektrum in Config page. also the signal wire on that receiver im 99% sure is the outer pin and not the inner pin. pull that label of and i think you will find the pad where the white wire is in the pic is square indicating ground (negative)

1 Like

also where are the pins soldered to the FC pic please

1 Like

I completely missed the Spektrum setting, I’m heading home shortly and I will change that to see if if fixes it. I was very thorough in making sure that the sbus wire is the inside one, I referenced the pin diagram. I didn’t do any soldering on the FC, it’s a connector type that came with the cable installed. I’ll know in about an hour if that was the problem. Thank you for helping me work through this!

Let me know if ok…

1 Like

Oh hell yeah! It was an issue of me not selecting the correct receiver. I’m good to go now! You’re a lifesaver man! I can’t thank you enough!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.