Touble with Omnibus f3 flight controller and FS-iA6 Receiver BETAFLIGHT NO MOTOR RESPONSE

esc

#1

Hello. I am really confused here.
I have no trouble setting up and connecting the radio to the receiver that it shows it is connected on my radio’s screen. And also the flight controller looks normal; it has one blue and one red light when connected to the battery. However, after I installed driver and connected successfully with Betaflight and turned on RX3(since it is a f3 fc) and set receiver to be Serial Based Receiver and IBUS, I tried to turn the radio but nothing happened and throttle level kept very low about 858. So I guess it’s the esc’s problem??
Please helppp!!

In this build I used:
Racerstar RS20x4 4in1 ESC
Omnibus fs Flight Controller
FlySky FS-i6 Transmitter
FS-iA6 Receiver


#2

The FlySky ia6 receiver only outputs PWM meaning you need to use all outputs for all channels, not one. It doesn’t do PPM or Sbus/Ibus. If you are looking for 1 output for all channels, you’ll need to change your receiver.

Info here https://blog.dronetrest.com/flysky-radios-and-receivers-which-one-should-you-buy/ about 2/3rds down the page.


#3

Omg okkk thank you so much!! I’ll try that!


#4

Carefully of those wires… I would redo them and get some heat shrink around them
If they short out against each other your will have a bad day…

image


#5

Well spotted! Bad day indeed if they short out


#6

Oops…LOL got it thank you!


#7

Ok it works! I now can move around the drone in betaflight. However, it does not respond in the motor section of the betaflight. By just plugging in the battery the motors does not respond to my radio, so is it the esc’s problem?


#8

Hi it still does not respond in the motor section of the betaflight. By just plugging in the battery the motors does not respond to my radio, so is it the esc’s problem?


#9

I soldered pdb’s grand and voltage to both esc and the battery wire, one on top the other one on the other side, hope that is not a problem??


#10

Can you take a photo of what you have soldered what to please?

Also, have you changed the receiver yet?


#11

You can’t arm you motors via the transmitter when connected to betaflight its a safety feature.

You need to take your props off, - Go to the motors tab - and click “I have removed my props”

Then you should be able to arm from the transmitter.

Not sure what you have done there… Can you post a picture… ( little worried here)


#12

Yes, I got a flysky x6b receiver and I think that’s why the receiver on betaflight works just fine.


#13


#14

Ok. How are you using the X6B? PWM, PPM, or IBUS? And is this configured in Betaflight?

I thake it you have binded it to the transmitter ok?


#15

Yes I’m using ppm and its set up in betaflight; I connected the ppm cable slot on x6b and binded it. Now I can receive controls of my radio on betaflight but still no motor response.


#16

Also, I tried ibus once and plugged in the ibus slot on x6b and set on betafllight, which it works fine like ppm but no motor response.


#17

Ok. Presuming you have set your arming sequence?

In the Motors tab, have you checked the option for propellors removed? If so, you should be able to move the sliders to see the motors running. Does this happen?

https://flexrc.com/2017/07/05/calibrate-your-escs-via-the-motors-tab/ for reference, also states how to calibrate your ESC’s


#18

Ok thank you got it. And I have a Racerstar RS20x4 4in1 ESC.
What ESC protocol would it be?


#19

So after I set the slider to the maximum and then plug the battery in, there is no beeping at all. I tried with the battery on and move up and down the slider and all motors can spin except the 2nd one.


#20

It supports oneshot4, Oneshot125, multishot, Dshot150, Dshot300, and Dshot600. Just pick one from the protocol list that is applicable, Either Multishot or Dhot600 would be preferable