Receiver Trouble FS-IA6B with Omibus F4 FC


#1

I am having trouble wiring and configuring my FS-IA6B receiver with my Omnibus F4 Flight controller
From the receiver I wired the VCC to power, CH5 to ground, and Ch6 to RX6 on the flight controller. The receiver is making a connection with the transmitter, but the flight controller doesn’t respond to any input on the transmitter.
There is no response in Betaflight either.
I have images of how I wired it and have links to wiring diagrams.
I think the wiring might be correct, but something with the setup is off. Any help appreciated!


#2

@cleptilectic I think you might have the Rx end of the wiring incorrect (certainly for the more modern i-bus connection protocol). This is for a wizard so the flight controller end might be different - but have a look at this guide https://blog.georgi-yanev.com/fpv/setup-flysky-fs-i6-ibus/
which should help you get setup in the i-bus serial Rx mode.


#3

In that link he doesn’t really talk about how to wire it because the connectors have a default connection already. I may have a newer version of the receiver, because as you can see in the first image, the connector wouldn’t connect in the way he has it because there is no pin in the center there.


#4

Yeah - must be a new type - mine is the same as his. Center pin is 5v then the outside pins are ground and signal - my guess would be that how you have it is correct with yellow pin being the signal and black pin being ground - but you could try the reverse.

Can you grab me a screenshot of the ports tab and maybe a “diff all” from the CLI - I need to dig a bit deeper into your flight controller setup.

You could try RX1 instead - I’m pretty sure that would work.

Hmm - This is an F4 FC - which has issues with inverted\uninverted signals as it has no software inverters unlike an F3 or F7. I think the RX6 pad is an inverted pad used for SBUS.


#5

I found the issue. I had to flash the FC with the OMNIBUSF4SD newest version. Then I set it up with IBUS on VR6 and it worked. The throttle, pitch, etc. now responds in betaflight. However, the motors still don’t respond to just the transmitter when it is unplugged from the USB and the battery is plugged in. I know the motors work because I tested them in betaflight. Is there something else I have to set up?


#6

Hmm - have you set up an arm switch in the modes tab on BF configurator?


#7

Also please, please, please set your failsafe on the transmitter if you haven’t already.

Joshua Bardwell has a great video on setting up BF3.5 on his YouTube channel - almost all of which applies to BF4.0 as well.


#8

Yes I have. I set it at min 1375 Max 1800 and when I hit the switch on the transmitter it responds in the receiver in BF


#9

Just trying to get this right…

You turn on the transmitter
Plug in the battery
hit the arm switch
and nothing happens?

Are you still plugged into USB at this point?


#10

So when I turn on the transmitter, plug in the battery, and hit the arm switch, the motors will turn for 1/10 of a second and then turn off. Then it won’t respond to throttle or anything. Turning the arm switch on and off results in the motors turning on and off for a moment.


#11

Can you see anything in the goggles - I’m assuming that FC has an OSD and you have warnings turned on in the OSD tab…

If not please try it connected to the configurator and let me know if there are any arming disable flags showing?

arming


#12

The goggles won’t connect either, or I can’t find the right frequency. I’m using the eachine 007 pro goggles. The receiver for video is on and seems to be working (the LED is on).


#14

In the log I am actually now seeing that arming is disabled. The drone no longer does anything (not even moves the motors for a moment) when I connect and use the arm switch.


#15

My guess would be that something is triggering a failsafe or RXLOSS situation - it could be that one of the channels from your RX is dipping below the level that would trigger it (the signal should be between 1000 and 2000)

You won;t be able to arm when connected to the configurator for safety - you should see an MSP disabled flag in that box on the setup tab.

You can enable arming by using the switch on the motors tab saying you accept the risk then swap back to the setup tab and check the disabled flags.

as for the goggles I’ll need to think about it - too tired now - can you get a better photo of how the video and camera is wired up to the FC and video transmitter and I’ll look tomorrow.

Also I know that you know but I have to say “Take your props off when on the bench” :slight_smile:


#16

Here are the photos of the video transmitter and the flight controller. On the left is where the camera and the video transmitter are wired into the flight controller (3rd picture). I am pretty sure these are right, I followed an online guide very closely. I did hot glue them so they don’t break off, as was recommended by the guide I followed.


#17

The weirdest thing is happening. I’ll turn on the transmitter, plug the battery in, and I’ll look through the FPV goggles and the image is perfectly clear, I can see through the camera. 30 seconds goes by and the image gets worse and worse until it’s complete static.


#18

That sounds like thermal drift or thermal throttling - do you have an antenna on the vTX while doing this testing? The video transmitters get hot fast and if there is no air flow they can rapidly reduce the power to stop from overheating - this might stop once you get the props spinning.

Also is 30s long enough to see if you have any warnings when you try and arm?


#19

I think it’s definitely getting too hot! It works now when I arm it, actually! Thanks so much for your help!


#20

Here is what solved the problem for me:
The flight controller wasn’t configured for IBUS, so in Betaflight I flashed the FC with OmnibusF4SD (notice the SD) and chose the latest firmware (4.0.0 at the time). This fixed the connection issues. The loss of connection of the video transmitter was due to thermal throttling. The chip was getting too hot and wouldn’t transmit video.


closed #21

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.