Problems with new drone


#1

HI
Just wondering if anyone can help me. I have just built my first drone, I have flashed the correct firmware onto the flight computer and I have configured on betaflight. Nothing happens when i use the radio controll, no movement. I am using a flysky FS-i6x radio and a FS-iA6B receiver. They have been bound.
cheers.


#2

Hi, did you try with the battery plugged in as some fight controllers don’t activate the receiver when running on USB only. Failing that can you go to the cli tab and type this-> diff all
Then press enter
Then push the save to file button
Then post the file contents here?

Alternatively can you post a picture of the betaflight config screens for ports and configuration?

Also can you please let me know the flight controller make and model - and if you can a picture of how you have them wired up - the actual board if possible…

Thanks


#3

HI, thanks for your reply. I tried it with just battery and still no response.
hopefully this stuff will load up.

version

Betaflight / OMNIBUSF4SD (OBSD) 3.5.6 Feb 16 2019 / 13:29:46 (c28ca22f9) MSP API: 1.40

board_name OMNIBUSF4SD
manufacturer_id
mcu_id 003a0029574850022039354b
signature

reset configuration to default settings

defaults nosave

name

resources

mixer

servo

servo mix

feature

feature -RX_PARALLEL_PWM
feature RX_PPM
feature TELEMETRY

beeper

beacon

map

serial

serial 2 64 115200 57600 0 115200

led

color

mode_color

aux

aux 0 0 4 1050 1200 0 0
aux 1 0 4 1400 2100 0 0
aux 2 1 5 1050 1200 0 0
aux 3 2 6 1400 1700 0 0
aux 4 28 7 1050 1200 0 0
aux 5 28 7 1400 2100 0 0

adjrange

rxrange

vtx

rxfail

rxfail 8 s 1500

master

set acc_calibration = -14,-84,-21
set serialrx_provider = SPEK2048
set min_throttle = 1100
set align_board_yaw = 160
set osd_warn_core_temp = OFF

profile

profile 0

profile

profile 1

profile

profile 2

restore original profile selection

profile 0

rateprofile

rateprofile 0

rateprofile

rateprofile 1

rateprofile

rateprofile 2

rateprofile

rateprofile 3

rateprofile

rateprofile 4

rateprofile

rateprofile 5

restore original rateprofile selection

rateprofile 0


#4

@Kayl_S - What board is that? The diff says it’s an “Omnibus F4SD” but I don’t recognize it…


#5

set board align yaw 160, that is some strange angle.
are you 100% you got power to receiver when batt plugged in, double check connections, also make sure plug on receiver correct way round if not it will power up but send nothing out.
If you sort out please check your ESC signal wires, the one to motor 3 is SO CLOSE to shorting onto the FC ground


#6

Im not o sure about the flight computer, i saw some fella you it on youtube.
This is what it was labeled when i bought it. [F4 Flight Control F4 PDB STM32 Integrated OSD 5V BEC Flight Controller for Reptile Martian II 220mm QAV-X 214 Drone]


#7

I had to set the yaw at 160 because the board whent in backwards. was the only way to get to the USB slot. not sure if thats the right way to do it. There is a red light that comes on on the receiver when i plug the battery in and i have it plugged into ppm/ch1


#8

Hmmm don’t have that radio, are you sure its bound correctly, believe you should have a TX symbol on your radio screen if bound.
do you have a pin diagram for your FC and a screenshot of the config page you could upload.
also you say you have no movement on the receiver tab in betaflight, do you have coloured bars that sit at 1500?


#9

also double check your board align, 160 is strange, norm is 90,180 or 270!


#10

Ha your absolutely right I don’t know why I put it at 160. I’ll change it to 180. I am pretty certain that it is bound but I think I will try it in one of my planes. Also I’ll get you the screen shoot next time I get a chance to get on


#11


I have pulled the receiver out of a rc plane that i know for sure works and still no movement.


#12

Looking at the picture of your FC and the Pinout of the FC you have your Rx connected in the wrong place.

Top is where it is
Bottom is where it needs to be

Give that a go


#13

Also double check the pinout… the Pinout picture doesn’t match your FC… its close but not the same


#14

Ok i have moved the signal wire from the receiver and i now have movement on betaflight. But i cant seem to spin the motors up with the remote, they are working when plugged into betaflight and move them on the motor page.


#15

how have you got the FC to arm?
If on switch make sure when you switch to arm the slider moves to the set area.
If not you need to min throttle and yaw right to arm.
neither method will arm if throttle above 1000, make sure throttle is below 1000 at idle if not use menu on transmitter, use endpoint to set.