No motor output in BF GUI

betaflight
esc

#1

I just got a Omnibus F3 AIO V1.1 and I get no motor output in the BF GUI. I had the same issue with an Omnibus F4 AIO Pro that I gave up on as defective and moved to an F3. Obviously it is something I’m missing. The difference between the F4 setup I had and the F3 is I had separate ESCs with the F4 and a QBrain with the F3. Otherwise the same setup FrSky X6R on both via SBUS, 2204 2300Kv HobbyFan motors. Shows all channels active in the GUI but motor test doesn’t work and arming does nothing either. I had a Naze32 on this quad and everything was setup the same and worked perfectly. I re-purposed the Naze to my son’s quad to get him into the hobby. I’ve set up a Flip32 for one of my other son’s quads and had no issues there either. It only seems to be to the Omnibus FCs. The F4 was from Airbot and he won’t help me, (hence the switch to F3) F3 is from Banggood. Please help.


#2

The F4 and F3 have two different options for motor outputs. Pins and Mini Molex style premade cable do I have to select the one I use in the CLI or GUI by chance? I’m using pinouts not the premade cable.


#3

UPDATE: Ok so I had to switch to PWM mode in ESC setting in BF. Which gave me arm with Tx and motor control in GUI but throttle does nothing on Tx.


#4

Happy to hear you figured it out, that was something I was going to mention as just spoke to someone else about this issue on another topic earlier today :slight_smile:


#5

I still have no throttle input. I can arm but not fly.


#6

Hmm, is your channel mapping correct when you go to the the receiver tab in betaflight? Also have you calibrated your radio range and ESC?


#7

The range is good. On the Rx tab everything I do on the Tx reflects correctly on the tab. Thr, Roll, Pitch, Yaw, switches…All coincide exactly with what I’m doing on the radio. I have the qbrain all in one. (Skywalker Quattro) so not sure how to calibrate. It didn’t work with the way I’m used to…No battery, full Thr, plug in battery, no Thr, etc.


#8

Do the motors run normally when you test them via the motors tab?


#9

Yes they work exactly like they should. Individually with each motor slider and all 4 with the master slider. It’s just when I disconnect and arm they won’t throttle up. (the throttle does nothing. All the motors do start spinning when armed.


#10

It’s pretty frustrating that I can have 2 CC3Ds (Acro and Atom) 2 Naze32s (a Rev 5 and Rev 6) a $17 Flip32 clone off eBay and every one of them is flying withing an hour after installing, but both ventures with Omnibus’ yield the same issue.


#11

Upgraded to the latest BF firmware and started fresh and for some reason it worked. I don’t know why but I don’t care…


#12

@Snowhack

Hi Darren
Welcome to the world of multirotors :laughing: :laughing: :laughing:
Happy flying
Steve :slight_smile:


#13

What do I look for or check in the blackbox log or CLI to find out why the beeper starts screaming as soon as I arm?


#14

Hi
Have a look in MODES to see if you have inadvertently selected BEEPER against an AUX channel, if you have and that aux switch is active then it will sound when armed
Hope this helps
Steve :slight_smile: