Seemingly erratic Omnibus F4 Pro V3


#1

OK,

I recently purchased an F4 Pro V3 FC, and have been putting it into an HK H-quad frame.
I’ve set it up with Betaflight (I think it should be OK), and gave it a maiden flight. It was pretty darned horrible!

The motors accelerate quickly (at low throttle), then slow down (despite increasing the throttle) and start to randomly hunt. At around half throttle it may take off, but wobbles about pretty unstably. All pretty horrible!

It’s as if the FC isn’t sending sensible signal to the ESC’s.

Any ideas from anyone?

Could I get the problem because I haven’t removed the ESC red wires (I have the board being powered via the Bat+?
I’m using the default ESC protocol. Is that OK for ESC with SimonK firmware?
Does it sound like gyro problems on the FC? (I had to reset the forward position on the board, as the arrow on the quad simulation was nowhere near pointing the same way as that on the board. Could this be wrong?)

I put my mini KK board in the frame, and the quad flies (although I haven’t optimised settings etc, so the yaw is too slow, but it hovers stable, and responds to the TX OK).

Help would be appreciated.

P.S. I’ve built quads and tricopters with KK/CC3d/Naze32 boards and using INav and Cleanflight, so have a reasonable understanding of setting such things up.)


#2

Is everything soft mounted.


#3

My guess is that it must be the ESC protocol, did you set the ESC mode in betaflight to be pwm?

Also I’d you are using pwm, you can’t run betaflight loop faster than 1Khz. So if you do that it should be better.

My suggestion long term would be to either see if you can update the firmware on your ESC to blheli so you can use one shot protocol, or get some new ESC at some point.


#4

Hiya, Alex.

They are brand new Afro 30 ESC (from HK). I’ve used Afro’s on a number of my quads (with different boards) and they always been OK.Basically it’s supposed to be SimonK firmware on the ESC’s.

I did try PWM and I don’t think it made a difference. I’ll give it another go.I’ll also check the loop time (I hadn’t changed it from the default).

I removed all the ESC power wires (except for 1) and also disconnect the Bat + lead - but it didn’t seem to make much difference. I did get eventually it up into the air (at over half throttle), but it was not very stabilised etc.As if the gyro’s are hardly working.

Another thing I could do would be to transfer the FC to a currently working 250 quad frame, and see how it works with that (although they also have - lower current - Afro ESC’s.)


#5

If you are only taking off at half throttle, maybe you did not calibrate the esc’s correctly? Which could also explain why it’s not flying very well as the motors don’t have enough power to keep things steady. Just a guess?


#6

Strange that the ESC’s start at fairly high revs, drop down, vary, and only slowly start to increase as the throttle is increased.

However, I’ll redo the calibration as well (worth a thought).

Perhaps switch it to PWN protocol and redo the calibration for another try!


#7

I fully re-programmed the board (with chip erase), set the ESC protocol to PWM, recalibrated the ESC and (finally) gave it another go.

It’s still awful! :sob:

I’ve just received my AFRO ESC programming dongle, so could program them with BLheli (from what I read). It does, however, still feel like the FC is varying the ESC speeds all over the place.

Is it worth returning it to you, Alex, so you can verify that it’s OK, before I go and re-program all the ESC etc (I purchased it from unmannedtech)?

BTW, I don’t have the board soft-mounted. Other boards I’ve used have all been OK with the mounting I’ve used.


#8

If you go to the motors tab in betaflight, and test the motors that way with the sliders, does everything seem to work ok? make sure to remove props first

That is the best way to see if the fault is with your ESC that is at fault. If that all seems ok then we can look through the settings you have on betaflight to make sure everything is ok. Might also be worth looking at the blackbox flight logs (if using an SD card) to see what is going on with the sensors to check they are behaving, as there is a small chance a gyro could be bad, but this is unlikely.


#9

Yep - I have tried the motors (without props) on the motors tab in BF and everything seemed nice and linear.

Can I provide a dump of my settings etc for you to peruse (I’ve currently disabled blackbox flight logging, but can enable it).


#10

I’ve now re-programmed all the ESC with BLheli, calibrated them all to be exactly the same in BLHeli suite (min throttle 1080, max 1920), checked everything I can see in Betaflight and tried it again.

It sort-of flys - but is still pretty horrible. The motors don’t start up together, it’s not very stable, it’ll start to (significantly) wander sideways, and it doesn’t take off until waaay past mid throttle.

This is getting somewhat plain annoying! :rage:


#11

I moved the Omnibus across to my 250quad (which I’ve flown fine with a Naze32), and it was unflyable. All the same problems again - motors not starting up together etc (again, these ESC are SimonK , and I had changed the ESC protocol to PWM).

I finally got annoyed, and loaded INav on the controller, set it all up (of course all the motors are in a different config etc) and… it flies sensibly!! :open_mouth:

I have no idea what the hell is wrong with the Betaflight setup. I’ll now move the FC back to the H-quad (which has ESC programmed with BLHeli) and hope that it stays flyable! :pray:


#12

Yep - the H-Quad flies (with INav)! :slight_smile: A bit clunky i.e. it’s not nimble - but at least now I can mess about with the settings.

Even have the GPS working - but not the Magnetometer yet (not sure if that works in INav yet, or if it’s just connections / settings I have wrong).


#13

Looks like the magnetometer in my first GPS module wasn’t working.

I’ve just tried a replacement one and the mag (and GPS) now gets recognised by INav fine! :relaxed:

Of interest, I also reloaded Betaflight onto the FC, and that still was awful to fly etc. I have no idea why INav has no problem, but Betaflight (that the board was, apparently, designed for is so terrible.)

BTW I took the quad out for it’s first actual INav maiden flight (rather than a hover in the garden) and it was nice and smooth.