SBUS not working on Omnibus F4/XSR

frsky
omnibus

#1

I built my 5th quad based on an Omnibus F4 board last night. Unfortunately I can’t get this one to show any activity from my transmitter in the betaflight receiver tab. The TX is bound just fine, I’m receiving full telemetry from the smart port link, I’ve configured the board for serial rx (SBUS) and enabled the port (just like my other 4 builds! :slight_smile: ).

I’ve tried direct soldering the XSR rx output pad to the FC, still no joy, and multi reader shows continuity from the rx to the fc pad. I’ve ordered up an x4r to try that out, really hoping it’s the rx that’s playing up and not the fc since I’ve soldered everything else to it!

Anyway, thought I’d post up in case anyone had any other suggestions on what else I can look for to spot where this is going wrong!


#2

HI

The first thing to check, have you soldered the SBUS/PPM jumper on the board to set the RX pin to SBUS? (SHort the SBUS and middle jumper)

Also I dont know if this is still a bug with betaflight, but before you sometimes had to select serial rx and sbus in the configuration, save, go turn on serial rx on the correct uart port within the ports sab save, go back and select sbus again, save again.


#3

yeah I’ve done that, config all looks good, just nothing coming through in betaflight. Will try cppm just out of curiosity.


#4

Hmm strange, might be worth also trying your Rx on another UART port. Although frsky recovers do already have an inverted SBUS signal so should work where you connected it.

OMNIBUS F4 (non pro) has many places you can connect your serial receiver:

  • (1) SBUS/PPM (J7) header (uart1) This is for inverted signal receivers; has fixed inverter that can not be turned off (by cli command sbus_inverter=on/off).
  • (2) RX1 (on J2) (still uart1), RX3 (on J1) and RX6 (on J6). These are for non-inverted signal receivers.
  • (3) DSM pin (on J8). This is for non-inverted signal receivers, and is equivalent to RX1. Rarely used because (2) is available, except when connecting DSM receivers.

#5

UART3 & UART6 are in use for IRC Tramp and smart port telemetry. Might have a go at tapping a non inverted signal from the xsr board and try J2. CPPM to J7 didn’t work either.


#6

No joy. Tried J2 with cppm and inverted sbus (didn’t want to risk trying to hack the un-inverted sbus signal from the rx). Neither cppm or sbus gave any input in the receiver tab betaflight with the appropriate configuration applied in each condition. It’s like uart1 on the board isn’t managing to receive a signal at all.


#7

I have just been playing with one of our omnibus F4 V3 boards today to see if I can replicate your issue. What I found that is if I am using the firmware that was shipped with the boards (v3.1.0/v3.1.1) with hte latest version of betaflight, the SBUS/PPM settings where not being written to the board. But after updating to firmware v3.1.7, I was able to write the settings and it works fine after soldering the jumper for SBUS.

So hopefuly that is the issue you are experiancing, so let me know what happens after you update to v3.1.7.


#8

Got to the bottom of it after getting a 2nd board and having the exact same problem. At that point I figured it must be something I was doing…

And of course, it was! The V3 board changed the UART assignments. I was trying to use UART1 for the RX, but now it seems it is UART6. D’oh.

Now to look into the horrible interference I’m getting on my video feed on this build!


#9

Hi Pepper,

I have the exact same problem as you did. Omnibus F4 v3, betaflight 3.1.7, sbus jumper soldered, Port UART1 set as Serial RX, configuration: Serial-based receiver / SBUS.

The receiver (XSR) is well bound to my taranis, and talks fine to other FC, but so far no luck with this one. I have to identical board, but both have the same issue. I tried to set UART6 as Serial RX (as well as UART3) but nothing new…

Any idea ?


#10

Afraid not, selecting a different port did the trick. Make sure your main config page hasn’t decided to switch away from serial rx/sbus for the recover mode each time you switch port.

I’m fairly sure I have one board that required me to use uart3 and one was uart6. I suspect this may be related to resource mappings in betaflight but haven’t dug into it. It sure would be great to understand how the resources in beta flight (a1 etc) map to the board labelling.


#11

Thank you very much… My FC didn’t communicate with my receiver…

In all the boards that I used before, the bus communication was in UART1… in my current omnibus board it’s in UART6.

Thanks to you I have found the solution for my problem.


#12

I have the same problem my omnibus F4 V3 doesn’t communicate to my XSR receiver, I did a lot of things following some of the suggestions but no luck, is there any new solution for this problem? Thank you.