Omnibus f4 v4 help


#1

Hi noob here I’ve just purchased a omnibus f4 v4 and a spektrum drone race serial receiver but can’t get it to work on beta flight do I need to solder the small pad where it says ppm sbus I am understanding I need to solder the middle pad to sbus to make this work thanks in advance


#2

There have been so many versions of the omnibus board that I can understand its confusing! The V4 does not have any solder jumper you need to modify. To use your spektrum gear, you just hook up your sattelite receiver to the DSM port next to the USB:

Then you need to bind it via the CLI in betaflight, we have a guide for that here:

If you have any more questions, just ask :slight_smile:


#3

Thanks Alex worked great once I reset the drivers to flash the new firmware as it kept failing to open serial port


#4

Also is there a magnetometer on the f4 v4 as I’ve tried to activate it but the calibration tab is greyed out


#5

No, there is no magnetometer on the omnibus board :frowning:
But well done for getting it all working :+1:


#6

Well it’s all ended in tears plugged in the esc’ s to calibrate the motors connected the battery and the flight controller blew :pensive:


#7

O no, do you know what caused it? :boom:


#8

I have no clue faulty opto esc ? Something is clearly wrong :weary: