Problem connecting to pc

betaflight
windows

#1

Hello. I am in need of your help. I am a beginner in fpv quads and I used my pc for betaflight. Today when I connected my quad it wasn’t recognised at all. I tried anything I could find on youtube and forums but the problem is that it doesn’t even appear as connected so it won’t show up in device manager or zadig. I even tried bootloader mode with no succes. The LED on the FC lights up and I get the sound when I connect it. The quad is an eachine x220s. Do you have any possible solution to this? Thank you in advance


#2

What do you mean with anything? Please be a bit more specific about that.
Is it possible that your FC got damaged somehow?
If you get the Sound while connecting it but it wont show up in device manager suggests that you have a driver problem.
Try reinstalling your Drivers also try to use a different USB Cable and a different USB Port.


#3

I tried every usb port on my pc and reinstalled all the drivers from betaflight. I don’t think the FC got damaged since I didn’t crash recently and only got 3 flights in angle mode since I last successuflly connecting to the pc. By anything I mean enything I could find online like driver fixer which gets stuck at searchung for flight controler.


#4

Have you tried using different drivers and not the same ones?
Maybe your OS got a update which mixed some things around.

I am personally using this one:


#5

I just tried this driver but it’s the same. The thing is that I don’t hear the sound of a device connected on my pc even if the fc led lights up


#6

so… the last one is right?
or the first one?


#7

I get the sound from the FC but not from the pc. The pc usually make a sound when connecting an usb device but nir when I connect the quad


#8

try a different usb cable…
All usb cables can give power
others can make that data connection.


#9

I used the setting on the OSD to change some stuff and everything seems to work fine there so the FC should be ok


#10

If the device is not being recognised by the pc then there is something wrong with your pc.
Did you enable “Show Hidden Devices” in your Device Manager?

Have a look through these:
https://www.virtual-serial-port.org/articles/com-port-on-windows-10/


https://answers.microsoft.com/en-us/windows/forum/windows_10-other_settings/com-port-is-missing-ports-option-not-available-in/f7d9b7b7-a3bd-454a-b5a7-0a9e29c0bb60?tab=AllReplies#tabs


#11

I had that problem and I tried like 4 different usb cables, only one worked. Keep trying different cables.

May be you have the same problem.


#12

I will try when I get home. Thank you!


#13

If you have a ps4 I can tell you that the cable you use to charge the controller works as that is the one I’ve used. Might also be worth trying this driver fixer