Omnibus F4 VS FC in a Eachine Wizard X220S

wizardx220
betaflight

#1

So fresh out of the box I followed the setup instructions to the tee. When it came to connecting the quad to my computer and flashing firmware via Betaflight I ran into major problems. The quad was not recognized as a USB device and Betaflight continued to immediately disconnect. I tried Zadigo, I downloaded the STM32 drivers. I tried on a WIN7 machine and a WIN10 machine. I tried several different USB ports. I uninstalled USB device controllers and rebooted. I even dissembled the quad down to just the FC board and held the bootloader button while I connected to the micro-USB and never once was it recognized as a USB device. DOA Omnicbus FC or am I missing something here?


#2

Hey eagleeye,

I think if you watch this Video i dont need to explain why your Betaflight didnt work :smiley:

Kind regards
Luca :slight_smile:


#3

Wow I completely missed that part of Betaflight being moved off Chrome apps. I will try the new URL but that still doesn’t account for why my computers won’t recognize the quad as a USB device when I plug it in. Without that piece I still can’t get it to talk to Betaflight correct?


#4

That should be correct.
Maybe your Cable isnt made for Data transmission…
Try to change your Cable that you use to connect your Quad to your PC.
Some Cable are only made for charging, like some Cables of Powerbanks.
Or try to use a Cable with USB 3.0 Instead of 2.0.
I had a Cable with USB 2.0 but i didnt work properly…

Luca :slight_smile:


#5

All I can help with is a link to download BetaFlight so you can run it outside of Chrome, which is where it’s headed anyway. the windows version seems to be ok, just tried it.

Download BetaFlight here: https://github.com/betaflight/betaflight-configurator/releases

You may have done that a gazzilion years ago but may help.

Good luck.