Eachine Wizard 220 flight controller issues


#1

Hi all I’m new to all this & I’m having issues connecting the flight controller one new Wizard to Betaflight.
When I plug it in to the USB a steady blue light comes on & a red flashes for a couple of seconds then goes out.
Windows comes up with a Ian defective device notification when I unplug. Betaflight fails to connect to port.
I’m stumped at the moment, I downloaded the drivers on Betaflight. 4 hours in & still nowt :confused:
I’d appreciate any advice short of stripping it down & losing any warranty.

Thanks Nick


#2

I think is is likely to be a driver issue, but do you have any other F3 FC to test to make sure it’s not your PC that has some driver issues?


#3

Just out of interest have you actually flashes it to betaflight?

If not download clean flight and try connecting through there! It comes running cleanflight out of the box!


#4

Thanks Ollys
I’ve tried it with cleanflight. Same result :confused:


#5

No Alex. I don’t have another FC but I do have another computer so I’ll try installing Betaflight on that. Then if needs be I’ll install the drivers & see how o get on.

Thanks,

Nick


#6

It’ll not connect so I can’t flash it to anything at the moment but I have another PC just invade it’s a fault with a driver installation.

Thanks, Nick.


#7

In case not invade. Night shifts :joy:


#8

Listen Nick1, try this:
basically, it sounds a bit weird but there’s 2 holes in the F3 board and you need to un fold a peper clip and bend it to fit the two ends in these holes. when you connect the the fc to betaflight it boots up the fc in flash mode.
Just watch this video, its really helpful

Go to 23:18 and he explains it. I’ve done it myself and it works.
All the best Michael


#9

Actually, you don’t need to jump the pins like Joshua stated, you just need to manually set the baudrate to 256000 and the board will flash just fine.

To the OP, I had similar issues with not being able to connect to my F3 board on my Wizard and all I did was use one of the fixed USB ports on my motherboard as opposed to one of the ports on the front of my case and it was detected no problem at all.


#10

It’s kinda sorted. Windows connects sporadically now. I’ve managed to get it set up in Angle mode & acro. Also changed arming to a switch & set it to drop on loss of signal.
Had my first 5 min flight with the 3s battery supplied.
Acro is going to take a bit of getting used to but I got it up & back down with no damage


#11

Thanks to everyone for their help & advice.


#12

Still not sorted. All I need is to add horizon mode as I need to progress but acro is too much for me as yet.
frustrated!


#13

I’m going to buy a replacement flight controller as I’m convinced the original is faulty.