Fly sky FS-I6 with Eachine wizard x220

wizardx220

#1

Hi … I bought this package as RTF out if the box…
However I be tried everything but can’t get the transmitter to talk to the x220 except for the binding process which has Tx and RX confirmed as set.
Strangely, connecting to Betaflight configurator the app shows the transmitter working in all areas … !!!


#2

Maybe:
-Try to bind the hole thing again. … (you will find a tutorial on youtube…)
-Double Check all settings
-Double Check all wiring
Order of this is : 321 :smiley:


#3

Also if it’s talking with your FC (you see the bars moving on the reciever tab in betaflight), then I suggest you check the arming settings. Best to use an arming via a switch on your radio.

Otherwise issue could be your mind throttle, as betaflight will not RM if throttle value is too high (I think it needs to be below 1080 or something. You can fix this with end point/sub trim settings on your radio


#4

Hi Alex,.

Thanks …,I now have it working fine…

However, as a newbie it’s very hard to fly…
Are there begginers modes I can set or any tutorials to learn how to control the wizard x220?

Many thanks

Phil


#5

Maybe try a Simulator…
Or… Set the Rates on the Standard etc… Without Expo etc.


#6

Yeah, check out our guide on the best beginner modes for betaflight

And as @Luca said, you should also spend abit of time on a simulator to help get a feel for how it all works. @SkyRookie has posted a nice master list of FPV simulators

You can also use your flysky radio, you just need to get a USB adapter