Omnibus F4 - cannot connect through USB


#1

Dear,

I am new with the Omnibus F4 control board and I have already a problem. When I was exploring the board with a Betaflight configurator I dissconnect the USB button(save and reboot) and now write “Failed to open serial port”. I am trying with the drivers installed (recommended) and ImpulseRC(still searching), with Zadig I do not see anything like STM32? I ma using windows10(64). Do you now any solution?thanks


#2

Your usb port may have locked up.

Try rebooting your computer it can help sometimes.


#3

I tried many times and did not help. Thanks


#4




I think there is no need to explain :wink:

Luca :slight_smile:


#5

swapping usb cables and usb ports on your computer?

You could trying putting the board into DFU mode.
By holding a boot switch while you plug it into your computer.
Run the ImplulseRC tool
Then try reflashing the board.


#6

I was searching all day today and now when i saw all movies on youtube, try impulseRC fixer and Zadig, different USB cables and now I tried the third port of USB on my computer, push the boot button and suddenly work and ImpulseRC fix the problem. I was flashing the board and now it is normal. And I am still do not know, what is the problem…USB ports, cables?Thanks


#7

Its a Windowism.

Sometimes windows plays how you want, sometimes it just stops for no reason.

Glad your back up and running


#8

This is a helpful link https://youtu.be/Ur_mU7Eu69E


#9