Omnibus F4 corner driver problem


#1

Hi all

I stuffed up while trying to install my drivers for my Omnibus F4 corner. It worked straight out of the packet but tried to install the bootloader using Zadig. The driver now calls itself “Omnibus F4” in Zadig and “STMicro…” on the device manager. I rebooted and now the FC isnt being recognised by Betaflight. I installed ImpulseRC to see if i could fix it but it gets as far as “Entering Bootloader” and i get an error of “unexpected number of devices”. I tried it on an other PC using ImpulseRC only and it works fine but need to fix it on the laptop now. In the device manager I have deleted the drivers but it always reinstalls the same drivers when i plug it in. Is there a way to download the drivers and install them manually?

peterc


#2

Hey pcampi,
It is possible that it wont work sometimes…
Here are some links to different Drivers…




If you need a 32bit Version, just ask me or visit the Flyduino Website…
They provide the Software that you need…:wink:

Luca :slight_smile: