Fix any STM32 DFU Drivers issues when flashing Betaflight/Cleanflight firmware

cleanflight
betaflight
flightcontroller

#1

Many months ago if you ever had any issues with connecting your flight controller to cleanflight/betaflight or any other variation the defacto suggestion would be to first install the suggested drivers for that flight controller and then use the Zadig Driver tool to reinstall the WinUSB drivers which solved 99% of issues.

Use ImpulseRC Driver Fixer Tool

However now there is an easier way thanks to the impulseRC driver fixer tool!

Essentially what this tool does is when your board is connected it can detect which VCP drivers it needs and will install them for you automatically! Nice and simple.

Last resort, select the driver manually

However if that still does not work when it comes to flashing firmware in DFU mode, the last solution is to simply select the correct driver yourself via windows device manager with your flight controller connected in bootloader mode.

Simply select the STM32 Bootloader device within the device manager, right click and select update driver software and follow the images below

That should solve any driver issues but if you still have any questions/problem let me know so we can try figure it out and add it to the guide


Sp racing F3 mini won't connect to usb
SPR F3 EVO fail to open serial port
CC3D Conroler Problems Connecting to OpenPilot
Cannot connect Furious Kombini to Betaflight
How to update firmware on Crusader GT2 2017 (Fury F3 OSD)
Can't connect Vortex blade to BetaFlight please help!
Flight controller wont connect to betaflight and not recognised by my pc
Can't arm quad in betaflight
Kingkong does not what to work
Diatone Tyrant S 215 replacing FC
#2

Should one consider removing the Zadig Driver to allow this utility to run unfettered or does it even matter?
Thanks in advance for your help,


#3

Should not make much difference as the impulse driver tool will overwrite and incorrect drivers anyways.


#4

Hey, I recently bought some Kiss 24a ESCs and the Kiss FC too, stupidly didn’t check the board on the PC first as I was too excited and wanted to get my first DIY quad built, and when I connected it to the PC the first time Windows chimed saying it detected the USB device, but I couldn’t get into the Kiss GUI, and I tried to use Defuse to flash the latest firmware on it but nothing gets picked up at all.

Now when I try hooking the FC up my PC doesn’t even detect that there has been a USB device connected at all, it’s driving me crazy, I think the board may have been faulty on arrival but me being a noob and not thinking straight I didn’t test it first, I’ve ordered another one, but just wanted to know if there was anything that I could do with this one to bring it back to life.

I’ve tried this Impulse tool but because my PC and the 3 other PCs I’ve tried it on doesn’t even detect that I’ve connected a USB device up to it the tool isn’t able to install the drivers for it.

Really frustrating, it is driving me nuts!!!

Any help or advice would be greatly appreciated as I’m at a complete loss as to what else I can try, I should also mention that the blue status light doesn’t come on, only a solid green power light.

Thanks in advance.


#5

Firstly, the shop you purchased your FC from should definitely replace/repair it for you as if its not even recognised by the PC when its connected then it is likely fried.

Just a question do you even hear the USB device sound when you connect your faulty FC, it it even listed as an unknown device in the device manager? And do you see any LED on it when its connected via USB. If no to both then you should definitely get a replacement as its DOA.

Otherwise the Kiss wiki has a great article on troubleshooting your driver issues -
http://kiss.flyduino.net/dwkb/troubleshooting-for-stm-windows-drivers/


#6

Hi mate, thanks for getting back to me, it is very intermittent in that if I connect it to a computer the green light comes on solid and I get no blue light, also the PC wont even pickup I’ve got a device connected at all, but if I leave it plugged in for a while it will make the USB connected sound but then it will disconnect itself pretty much straight away.

I already contacted the place I purchased it from and was told to try and flash it with the latest firmware but if I can’t even get my computer to detect it in normal mode and DFU mode then I have absolutely no way of trying to flash the latest firmware to it!!!

I’ve actually contacted Flyduino and I’m awaiting their response, I’m hoping that I can maybe send the board to them and see if they can sort the problem out as I am at a loss as to what could be causing this, I don’t think Quadcopters.co.uk would replace this board for me though as I stupidly didn’t test it first because I was so excited to start my build that it completely slipped my mind, however I have no doubt that the board was DOA because my soldering was done at the correct temperature and I did a clean job with it too.

I don’t suppose you have any ways that you could test and maybe try to repair the board for me if Flyduino aren’t able to help?

EDIT: When the PC does actually pick something up it shows as an Unrecognized Device in Device Manager, but it will disconnect by itself almost immediately, and I actually went out and bought another Kiss FC which I’ve had hooked up to this very same computer using the same cable and it works just fine.


#7

Yeah, it does sound like a problem with the board if the new one works just fine on teh same PC. Hopefully you will be able to get it replaced so you have one spare as should not have a problem replacing it for you as often you need to solder it before you know if it will work or not.


#8

Hi, the program ImpulseRC does not work for me, but then I tried to follow the video, but the last step when you press “STEM Device in DUF Mode” I don’t have that option ’


#9

I have brand new fip32 f3 AIO-lite board and II have been trying to connect and flash it many different ways with many different drivers and updates and my beta and clean flight both keep failing to connect to serial port and I an not connect or flash my firmware… Ive even tried the manual driver thing like suggested above, that changes nothing. The only thing I can think of is that my Zadig and Device Manager never actually say Bootloader anything when they connect and recognize the chip is connected successfully.

Can someone please help and suggest something.


#10

it never says anything like stm32 bootloader in my device manager when my chip is connected and the led’s indicate boot loader mode.


#11

I am not super familair with the flight controller you have, but i think it will have some boot pins that you need to short while powering it on for the board to enter bootloader mode. Check the manual if you have one.


#12

Hi
I did all of the above . On the USB list I can see the boot loader . I used both tools mentioned above . I think drivers are correct but Betafligth still cannot connect to my drone. I read somewhere it could be the USB cable . I tried a couple but what difference should I look for ?What make an USB cable better then another ?


#13

It could also be that your FC is dead. I find that if you connect it with the bootloader button pressed in, then run the impulserc driver fixer it will find the dfu device, you can then flash firmware onto it. Then you repower your FC and run the driver fixer again to install the regular drivers and you should be good to go. Or your FC is damaged :frowning:

USB cables can sometimes have bad connections in them so using another one can rule out an issue with the usb cable itself, also try another usb port/pc to make sure.