SPR F3 EVO fail to open serial port

spf3
flightcontroller

#1

Cannot get cleanflight to recognise the board. It will flash in DFU but afterwards will not connect. Updated drivers and tried Zadig. Starting to wonder if I have a faulty board, but its more likely me doing something wrong. Any help would be appreciated.


Cleanflight wont flash onto SP Racing F3 FC
#2

Do you get the error message within cleanflight saying failed to open serial port? If so then it sounds like a application/driver/PC setting. As this usually happens when an application does not release the serial port. Have you installed the Virtual COM port drivers from this link - http://www.st.com/en/development-tools/stsw-stm32102.html

Might also want to try on another PC/restart you PC if you get that message to make sure its not an application that is using your COM port.


#3

Unfortunately don’t have access to another computer. I do get that error message. Yes have downloaded those drivers. They are failing to connect in device manager. STM32 drivers uninstalled is the reason it gives. Don’t understand that?? Does zadig really need to be installed or is that just for boot mode?


#4

Alright, I assumed that was the issue since it was the title of this topic :stuck_out_tongue:

Buy yeah its worth giving zadig drivers a try first as I had similar issue when I first tried a FC with the virtual com port and after messing around with zadig I got them working perfectly.


#5

I got rid of all the drivers I had installed for cleanflight, got rid of zadig. Anything and everything to enable myself to start from fresh on the whole process. So now have reinstalled the drivers but it won’t install Zadig. I am, as you mentioned earlier,pretty sure its this computer. But its all I have and i managed to get on cleanflight on the same machine with my naze boards. Problem I have at the minute is my very limited computer knowledge. The virtual com port on device manager has a yellow triangle in front of it. Windows asks if I want to update driver to make it work. I tried and it went on an endless search of the internet, so i ended that. All I need to do is get that Com port working and I think I will be in.


#6

@mrcountmeout
Try the auto update of the driver with the yellow triangle, I know it takes ages/hours but in the past I’ve found it gets there eventually. An overnight try ??
Failing that post snapshots of all the property windows for that driver and we may be able to identify it and supply a driver file, FWIW :persevere:
Cheers
Steve :slight_smile:


#7

Hey guys, thanks for your help but I have sorted it. Dowloaded a Driver installer from STI and installed the driver updates with that. Now have com3 on cleanflight and betaflight. VCP_V1.3.1_Setup was the installer. Hope maybe that may be of help to anyone having the same issues I have. I think maybe because I’m on a four year old netbook? But I’m sure I’m not the only person in the world who is. Thanks again.


#8

I’m having an identical problem I have download and reinstalled the various drivers including VCP as mentioned above but still no virtual port. I have zadig installed but still nothing. Any suggestions gratefully received. This board did connect originally but now for some reason it won’t. I’ve also tried connecting the boot loader pins.


#9

Hey, if I’m being totally honest I mostly Forest Gumped my way through it. Download all drivers, zadig etc etc, don’t forget to reboot computer afterwards. Also (interestingly(?)) When the computer still refused to connect and I went on device manager to see vice com port was still inactive I let windows update take care of it (it took an age) but it found and automatically installed the drivers I needed. I am currently trying to flash a cc3d revo f4 (my third of this board) and it won’t flash. I can honestly say flashing flight controllers these days is an absolute pain in the arse. I wish I never had to do the zadig dance ever again. I understand there is an alternative method to flashing using another programme, I will try to find and use that method and post here. Good luck dude.


#10

Just had a quick Google and came across this thread…not tried it yet but certainly will be having a go


#11

After 3 hours and trying everything this fixed my problem in one click. ONE CLICK. Thanks!


#15

Do you have a link to the download please, im experiencing a similar issue


#16