Sp racing evo flashing

f3
cleanflight

#1

Hi all new to the forum

Now i have checked through some posts but none have really solved my problem
I have a spr evo fc and am trying to flash it with cleanflight
I can connect to cleanflight and everything is working but with the default flash
and it recommends to flash it with new.

Now i plug in my usb have a red blinking green steady and blue steady load firmware has the correct pot in top wright hand corner of cleanflight.
press flash firmware comms port disappears and says left hand corner failed to open serial port

HELP !!!

Have correct files as can connect to cleanflight just wont flash tried bootloader pins but still no joy
Any help would be much appreciated as i have changed to this board from naze 32 rev 6 du to vibration issues with my
emax 2205 2600

Thanks in advanced
Will


#2

Hi and welcome :slight_smile:

My suggestion would be try using zadig drivers to flash your board in DFU mode as that is usually the most common cause for firmware flashing to fail.

If that fails you might need to use DfuSe to manually flash your board via the .hex file


#3

Hi

Thanks for replying i have tried Zadig but it keep saying no devices found
I have no problem flashing my naze 32 rev6

i am sorry i dont understand this process

If that fails you might need to use DfuSe to manually flash your board via the .hex file

Thanks again.


#4

Hi
found out how to use Zadig and find my devices loaded new drivers restarted pc
opened clean flight
now weather this make any difference select spr evo 1.12 instead of 1.13 on cleanflight and it flashed straight away

Went back and tried to flash 1.13 and it closed serial pot again

so use Zidig and flash 1.12 instead of 1.13

Thank you


#5

Thanks for letting us know, interesting point so maybe v1.13 has some sort of a bug