Sp racing F3 mini won't connect to usb


#1

I have connected flight controller through usb, Activity light was flashing. Then i connected to the clean flight and went on the kitchen to make a cup tea without disconecting. When I’m back the board stop flashing completely through a usb port, but once I attached the battery, everything starts work fine, but no response through usb port alone, seem to be no power going in, or what is wrong with these boards? I bet everybody having difficulties with special racing f3 mini. What do you suggest? Any additional information would be helpful on how to reload.
I already have 2 of them, one was factory damaged and the other lost communication with USB.
It’s just odd that one worked perfect and the other doesn’t.


#2

I have the SP Racing F3 Deluxe board. and have a similar problem I have found that when the board is connected via the usb I have a green light that flashes rapidly and a red light that flashes when the board is at an angle.
When the board is placed flat the red light stops flashing, when the board is in bootloader mode there are no lights flashing but the board will still not connect to Betaflight.
I think that I have not got the correct drivers installed on my pc
I have Silicon Labs CP210x on ports in Device manager but I am unable to install en.stsw-stm32102
Hoping someone can help.


#3

In your photo is the board only connected via USB? As in the oicnit seems to have power ok, but if you just can’t connect then it is likely a driver issue. Are you using a USB hub? as its usually best to connect directly to the PC to ensure it gets enough oower

I suggest you try the driver fixer tool first to make sure that is not the cause