Windows doesn't recognize flight controller

Whenever I plug in my flight controller (mamba f722s) to my pc I get a message from windows saying it is not recognized and it doesnt show up at all in betaflight. When I first got the flight controller I made sure it worked by connecting to betaflight and I flashed new firmware which also worked. Now, I plug it in, it gets really hot and has a solid red led with another fast blinking red led at the start, there is also a very dim blue led slowly blinking.

Please help, I would appreciate any type of support.

Thanks in advance :slight_smile:

if after flashing FW you have had it working and if its new return it, if it get very hot within 10- 15 second its broken.

Thanks for the response

After flashing firmware I could access through betaflight, however I couldn’t get it working with the rest of the components and after that I couldn’t access betaflight again.
About the heat though, I thought stm32 flight controllers are meant to get really hot.