[RESOLVED] Betaflight - No Configuration Received

spracing
cleanflight
betaflight
flightcontroller

#1

Hello, I am trying to get a previously working SPRacing F3 flight controller connected upto Betaflight/Cleanflight however I am receiving the message that “no configuration was received within 10 seconds, communication failed”.
The serial port is visible and successfully opens just fine, I was also able to reflash betaflight onto the board without any issues however I am still receiving the same error when trying to connect. Any suggestions? Could connect fine just last week…


#2

I have not had this issue before with betaflight, but has this issue on some older boards and problem was either a driver or firmware/bootloader issue. My suggestion would be to try reflash the firmware onto you board again, also you might want to try an older version of betaflight to see if that helps too.


#3

Thanks for the response Alex, I have been discussing the issue with the guys over at rcgroups https://www.rcgroups.com/forums/showthread.php?2387038-SPRacingF3-Racing-board/page178#post36579729
I have flashed the board multiple times with multiple different versions of betaflight and cleanflight, none of which work. Flashing process goes fine but then I receive an error trying to connect.
I do not believe it is a driver issue as I was able to connect previously without issue, tried reinstalling the drivers anyway with no luck.
Board is only a month old, purchased it from you guys at unmannedtech last month and only had a couple uneventful, smooth flights with it so far with it so I am really hoping we can get it working again if you have any further suggestions


#4

Yeah that is very bizarre. After you flash and reconnect it to you pc, can you go to device manager and just see what driver is loaded as maybe the FC is stuck in bootloader mode?

Otherwise last thing is to try on another PC if you have access to one to double check but I am fairly certain that is bootloader issue if you can flash always, but never connect. If this is the case the just send support and email with your order number and ki k to this thread and we can get it fixed for you.

Also might be worth double checking the boot pins are not shorted somehow?


#5

ok, definately an issue with the board. I plugged it in to check the drivers and it managed to connect to betaflight this time. However, the gyrometer and accelerometer sensors were not being registered and the I2C error counter at the bottom of betaflight was going up into the thousands.When I tried changing a setting the board rebooted and now I can no longer connect to it again.
Will go ahead and contact support, thanks for the help