My Flight Controller can't connect to Betaflight (Serial port successfully opened -> serial port successfully closed)

Hi everyone, I’m trying to program this flight controller: (https://www.horizonhobby.com/flight-control-f3--torrent-110-fpv-spmfcmf300) for a personal project.

I got betaflight to open the flight controller with no problems whatsoever the first time I tried it and then many times after that as well. But then I couldn’t figure out how to connect my Taranis qx7 to it and so I was troubleshooting and disconnecting and reconnecting multiple times to test it.

All of a sudden I can’t connect anymore. Flight controller still powers up and Betaflight still recognizes it coming in as COM3 (115200) but when I click the “Connect” button it does the following:

  1. Writes “2019-09-07 @ 21:14:26 – Serial port successfully opened with ID: 3” at the top left corner of the screen.
  2. Waits about 10 seconds.
  3. Writes “2019-09-07 @ 21:14:36 – Serial port successfully closed” at the top left.

I am pulling my hair out over how something can work so well and then die randomly. Here’s what I’ve tried:

  • installing all drivers that Beta flight has listed
  • Tried installing Zadig but it doesn’t show my FC in the drop down menu
  • Tried both the full software download of Betaflight and the Chrome extension (also tried RaceFlight)
  • Tried to flash the firmware but it tells me “No response from the bootloader, programming: FAILED”
  • Restarted my computer multiple times and uninstalled and reinstalled betaflight multiple times
  • Tried with and without the battery plugged in (don’t think it makes any difference)
  • Unplugged everything but the Micro-USB going to my computer

This thread: [RESOLVED] Betaflight - No Configuration Received
Says that they resolved the problem as just having a busted board, but then why would it connect and light up at all?

Does anyone have any ideas? Sorry I’m new here so I’m not sure if I’m breaking any rules. If you need any clarification just let me know.