Dlink-V2 cant connect to betaflight

f3
betaflight
dlinkv2

#1

Good morning. I just purchased a diatone dlink f3 flight controller and it won’t connect to betaflight. The first time I connected it it worked just fine. Then in betaflight in the log it said device reboot and no more data would load. I disconnected and trying to connect again only to have the log in betaflight say serial port opened successfully with id. It then says no configuration loaded in ten seconds, communication failed and then the port closes. This flight controller is brand new, literally just opened from the box.


#2

After a day of research and trial and error I found a solution.

The only way it was able to connect to betaflight was reflashing the firmware in a certain matter. I had to choose flash on connect and full chip erase. Before connecting the flight controller to my pc I held the bootloader button down and continued to hold it down until the firmware flash was complete.

If i did not flash on connect and hold the bootloader down the entire time the firmware flash would be successful but I would still get the no configuration after ten seconds error. I hope this solution helps for you and others.


#3

Well done. Also usb cables can be funny but glad you sorted it. Now get out flying!