Diatone d-link f3 v2 - no bars in receiver tab in betafllight


#1

Hello, I have the following setup: tyrant s drone with upgraded vtx (diatone sp3) and Hobbyking Turnigy evolution radio and ia6s receiver.

I had setup the vtx without osd (no connection to the fc) and everythi get worked just fine.

This morning I connected the vtx to the fc so that I can get info on the display. At first everythi get was OK and working fine. A few minutes later, for some reason, the fc stopped receiving radio signals all together. Keep in mind, the drone had flown and everything was fine.

I started debugging and I see that in the radio tab in betafllight I have no bars whatsoever. When that happened, I thought that some wire came loose or broke, I ended up replacing the wires between the receiver and fc and still nothing. I tried to set up a different mode (I was running ppm), I tried sbus and ibus with the right wiring and configuration but still nothing

At this point I am not sure what is broken - fc or receiver, something must be. How can I figure out what is wrong?


#2

I figured it out.

The D-Link F3 V2 FC supports only one serial connection at a time. So when I was connecting my OSD and USB to the FC and powering everything up, it would f@ck up configuration on the FC. Plus, the Betaflight GUI is a bit dumb and does not seem to display correctly some of the saved settings.

What i did to work around this is save the full configuration from CLI before every change / powerup. When it broke, i’d load it back up trough CLI.

Regards,