Replacement D-link V3 F3 Flight Controller no longer working for GT2

dlink
diatone
flightcontroller

#1

Hi,

I have a Diatone GT2 all stock components, has been flying great for a couple of months. I then had a crash where the props cut into the positive battery wire. When I went to retrieve it, I picked it up, and the exposed wire then touched the metal frame at the rear causing a spark. After that, I lost any response from the flight controller. (I wasn’t able to test quad after crashing and before the spark so I am only assuming this was a significant event!) VTX was still working and the receiver was still working. The CPU chip was hot when battery connected.

In response, I assumed I had blown my flight controller, so I ordered a replacement. I rebuilt the quad disconnecting all wires and resoldered everything back onto the new flight controller, with the only change being the flight controller. Everything seemed ok, I went through betaflight, without the main battery connected and could configure ok. Upon connecting the battery, I lost the flight controller, this time, the blue light no longer came on, but a red LED would now flash intermittently. CPU gets hot. Betaflight would not recognise and FC won’t startup. I fear I’ve blown it again! I wondered if it was a short but was as careful as I could have been to avoid any. I now wonder if it might be the ESCs/motors, if I got a replacement FC I wouldn’t want the same thing happening again even if I connect everything ok. I’d be really grateful for any help! So frustrating!


#2

Hi, I can imagine that must be very annoying after getting everything setup, only to have the FC not work at the end!

If you just power it via USB do you still get any LED lights? And I assume you have also checked through it all and made sure the soldering has not caused a short?

If you get LED;s with just USB connected but not when a battery is connected, then its likely a voltage regulator has been fried somehow (so if you ordered from us we should be able to get this replaced for you under warranty).

If you get LED;s with battery connected then maybe the CPU has just been bricked so you can try to flash new firmware but select full chip erase and boot on connect within betaflight (and also possibly manual baud rate) and that should work.

Let me know how you get on.


#4

Thanks for getting back to me!

Yes, the led in the image attached is the one that lights up. Its lighting sequence is: 3 fast flashes, followed by 2 slower flashes. This repeats continuously.

when I connect the battery, the motor sequence starts, beep-beep-beep, then nothing. It does not finish the rest of the sound sequence as I remember…
The red led goes from flashing sequence above to very lightly on. You can JUST about see that it’s emitting red light.

I tried to flash firmware but it does not appear to be able to connect to it. (no response from the bootloader, programming: Failed)

I did purchase the flight controller from you as well as the GT2 package.


#5

In my experience diatones boards are dogshit, get yourself another fc/pdb combo, lumineer Dys and beta flight all do all in ones


#6

Hi
I’ve had similar problems with three controllers on my GT2. I had voltage regulators go on the 1st two D link version 2. FC’s, & now the latest V3. looks like a similar fault to what you’ve experienced, probably the CPU chip fried?

I can’t fault the service from unmanned tech though as they’ve replaced the board under warranty on the three occasions.

I finally gave up on the Diatone board & have switched to the latest DYS F4, & as of now not had any issues. The board does fit just, on slightly taller spacers above the existing VTX, Although I’ve had to notch the two carbon side plates to allow space for the fixing screws.