Cant connect to my D-LINK F3 FLIGHT CONTROLLER

dlink
betaflight

#1

Hi All,

I have just bought a D-LINK F3 FLIGHT CONTROLLER WITH PDB and am connecting to it via my PC using the CP210X Module. When in Betaflight I try to connect but cant. These are the steps I have followed.

  1. I only have the CP210X connected to the board.
  2. Trying to connect via the listed COM1 using BAUD rate 115200.
  3. On manually trying to connect it follows this sequence:

Serial port successfully connected with ID2/4 etc then Serial port successfully closed.

I am using the latest Win10, I have installed CP210X drivers, STM USB VCP drivers, reinstalled several times to see if its issues with the drivers.

I have tried flashing with the latest Zadig for Windows, first putting the FC in to flash mode by holding down the on board button before inserting the USB in. The light is then blue but it is still not being recognised!?

On inserting the FC in normally I have a solid blue light, and a flashing red light which flashes 3 quick bursts followed by 2 slower bursts and repeats. I seem to have tried everything and cant connect or reflash the FC. I have tried several different computers as well. Do I need to send it back to be replaced?

Any help is appreciated.


#2

When you tried Zadig drivers did you install the winUSB drivers?

Also could you try another USB cable as sometimes that is the cause of problems, and are you certain the CP210X module is connected to the correct port on the Dlink FC and that none of the pins are bent?


#3

Hi,

When you tried Zadig drivers did you install the winUSB drivers? These are the drivers I installed:
WinUSB (v6.1.7600.16385)

Also could you try another USB cable as sometimes that is the cause of problems:
Same result with a different cable.

and are you certain the CP210X module is connected to the correct port on the Dlink FC:
Yes, its connected to the side opposite PPM,SBUS etc with UART1 on the left.

and that none of the pins are bent?:
I have visually checked the pins and connector and all seems well.

The only relevant connection I can see in the Zadig installer is CP2102 USB to UART Bridge Controller. Is that correct? Please see the attached image.

Thanks,


#4

If you go to device manager are you able to see the COM port listed there when the CP210X is not connected to your FC? Or is there an error as I am trying to figure out if its a driver issue or simply a fault with CP210X or the flight controller firmware issue.


#5

In device manager, in ports (COM & LPT) I can only see COM1


#6

It shows up here but only when plugged in:

I then right clicked on the above CP2102 and selected update online and I now have a COM3


#7

I was able to flash the FC with Betaflight (According to Betaflight) with these settings but still cant open the FC to make changes using Betaflight, still got the flashing red LEDs.


#8

Hi,

Any further help with this please?

Thanks


#9

One thing to check would be the baud rate of com 3 making sure they match.


#10

If you go on YouTube there is a step by step way to do this, I had no issues with mine. I didn’t have all those tags though, only manual baud rate and full chip erase. If you cant find the vid on YouTube message me and I will find it for you.


#11

Hi There! I’m having the same problem with my F3 D-link and wanted to know if you had success? Any tips? Thanks!


#12

Hi,

Sorry to hear you are having trouble.

The first thing I would do now is download the immersionrc driver fixer (Google it)

If that doesnt work then go to the betaflight wiki and make sure you have the recommended drivers. follow the instructions to instal them and try at least twice if it doesnt work the first time.

The next thing I would do is realise that Diatone stuff has not been good re the quality of the products they sell, good customer service but nonetheless bad quality.

My last piece of advice would be to buy maybe a slightly more expensive product but at least ones you know will be good quality. e.g. TBS stuff. I had maybe 3 Diatone FC that were defective and at least 2 VTXs (SP3) So I have now given up on their stuff, just not worth the hassle.

Good luck mate.

Steve


#13

Hey Bud, I JUST got it flashed. Turned out I downloaded but forgot to install the stm software.
That all gave me a headache. I got a D in college statistics so this stuff makes me ape.
Anyway now I’m having a prob with the turnigy a8s rx. It’s looks bound to my evolution but not doing anything and BF doesn’t look to recognize the connection either. This stuff makes my head spin. Gonna take a deep breath and relax and come back to it later. Thanks for responding so quick! You’re golden, best to you, John