No reciever respond on betaflight (fs-i6) altough its binded(Solved)


#1

Hey, im building a drone using this youtube guides:


So, im stuck in binding the remote controller to the VTX reciever, when I connect the battery I get a few beeping sounds and then its quiet, and a red flashing on the SP3 flight controller and on his other side blue steady light. So i connected the bind key to the B/VCC port and the power cable to one of the available ports. I click bind on my flight controller while I turn it on and it writes binding… but nothing happens, tried many times to figure it out with no success, waiting for you help, thank you.
Forgot to mention im new in building this its my first time building drone or any rc at all.
by the way I didnt flash any software to the quad, I dont know if its related, but when I tried to connect it with betaflight and cleanflight it recognized once with betaflight so I checked its version becuase only the CLI worked (cleanflight january 2016), but after I accidently exit the program without dissconnecting from the quad it didnt connect to the drone anymore, not with betaflight and not with cleanflight.


#2

“So, im stuck in binding the remote controller to the VTX reciever” Do you mean your goggles?, Because the only thing recieving your VTX signal is your goggles and not you transmitter. When you said remote controller Do you mean your Flysky transmitter? If so your question is impossible to answer because they operate at different frequencies 5.8ghz and 2.4ghz. Additionally, or do you mean connecting your RX to TX?


#3

Normally you just connect your VTX to your FC and it relays its video signal from the camera to be transmitted to your goggles. I dont know anything about flysky ecosystem but looks like stu steps are very clear. Maybe follow his instructions from the very start?.


#4

Okay, so it just shows my lack of knowledge, I thought the VTX is related to the controller, so no i dont mean to the goggles, lets leave it aside, I’m having trouble binding the remote controller to the reciever that I recieved with it.(FSi6)
What can I do?
edit: I have on my reciever a flashing red light but like I said I click on the bind key and turn on the controller and its writing binding…


#5

First ensure that the receiver wires are connected to the FC are soldered/connected to the right pads
Then connect the molex like connector to the receiver simultaneously connecting the binding jumper wire to the correct pins
Make sure your tx is powered on and turn it off.Connect a lipo to your quad and ensure you get a blinking red light on your receiver.( this puts the receiver into a search mode)
Power on you TX and voila bound together.


#6

Alright, so I managed to bind it thanks to you and this video https://www.youtube.com/watch?v=LAgiNxtn4Jg
Now I see in the remote controller the RX and ERR1:0% and there is no power when I try to throttle up, what should i do?


#7

could you possibly sent a pic


#8

Sure just a sec


#9

Cool when you mean no power the motors dont spool up?
Can you also check you PPM output is on?


#10

The PPM is on, Yes I mean I try to “level up” the drone and it just doing a beeping sound here and the motors and moving back and forward tiny spins…


#11

Have you set your arm switch
Or follow setting the endpoints? maybe https://www.youtube.com/watch?v=9-Z0rTVEkHI


#12

So I saw the video I did everything, my channels are 5 SwD and 6 SwA, but still no response when they are down and I try to “level up”
Its related to that I didnt do any flashing or something to the SP3?


#13

Weird what about the settings in betaflight/cleanflight make sure that the endpoints are calibrated and the right settings in the ports tab are correctly switched on? pic of ur ports tab


#14

So this is what I’m saying, I dont know what comes first flashing the SP3 or binding the remote controll, I had problem connecting the Quad to the computer, first the beta flight recognized it and I got connected but only in CLI mode, so I wrote /version and saw its cleanflight, I downloaded cleanflight and forgot to dissconnect from the betaflight and just closed the program, so when I tried to connect with cleanflight to the Quad it didnt succeed connecting to it. says just open port and closes after 10 seconds of no signal something like that.
Do you have maybe an email I can share with you a video I filmed? about this whole situation


#15

Sure my email is markjustinecruzado.mc@gmail.com


#16

may I ask what brand of FC are you using?


#17

Sure, my FC is SP3 Deluxe
this one:


#18

Do send me the video of the FC


#19

So now I connected the FC to the computer, again, the betaflight connects but only on CLI mode and the cleanflight doesnt connect at all, few secs sending the video
sent.


#20

is the red light flashing coming of the fc?