No reciever respond on betaflight (fs-i6) altough its binded(Solved)


#21

Yes the red light flashing its from the FC next to the UART1, and there is a steady blue light next to the UART3


#22

did it come with beta or clean flight


#23

Just uploaded it above, take a look
sent it to you, I’m blocked from the website becuase I passed 22 messages a day for new user4
still cant.


#24

So from what I can see betaflight recognises that your FC has cleanflight onboard so its trying to communicate only through cli so we might have to convert to betaflight from cleanflight? if thats what you would like to do?


#25

can you please safely unplug your fc from betaflight and can I see just betaflight config itself because it should have 3 tabs like this


#26

Before we proceed type dump in the cli in cleanflight configurator and copy and paste the settings and save in a notepad or something?


#27

@yahavz100

Try and post now…

I bumped up your trust level. So should be able to post if I did it right.


#28

he’s messaging me through gmail unfortunately shall I tell him to come back here?


#29

Either or buddy

Just post the solution if you get him going.


#30

i am currently helping him through the conversion of the FC’s fw from cleanflight to betaflight. We have solved the issue of binding the rx to tx and now we are flashing his FC


#31

Alright so after we succeeded binding we were stuck in flashing the frimware to the drone, Mark send me this video:


Which helped me to solve the problem.
After that I configured my FC in BF as in the vidoes I posted earlier,but now im stuck, there is no respond between my transmitter to the motors, when I checked the motors in the betaflight they worked perfectly, I tried to search in the internet and did an ESC calibration but I’ve found that there is radio calibration which I dont know if I need to do according to my build, looking for your help thank you.
Ofcourse a lot appreciation to Mark that did awsome job and explained and helped how to go through this whole process.
By the way, later I tried to bind my Tamiya Manta Ray RC car with the FS-i6 transmitter and its reciever,they both binded and it worked, the channels were messed up becuase I didn’t manage to understand how to do that right, but eventually it managed to get the motors moving back and forward and the steering left and right, so I guess the reciever is fine.
(If someone knows how to manage the left and right in the RC car to move on the right gimbal of the fs-i6 would be helpful, for now I did the left gimbal will do everything).
Maybe in order to get to the problem I noticed while in betaflight I dont have any battery voltage status while its connected to the drone, and like I said the throttle doesnt respond in the reciever tab, altough my vbat connection is soldered and connected with other 3 more wires(4 in total) directly to the ESC



#32








I have attached a couple of my settings and links
First look at your ports tab and ensure that your rx is in the right uart.
Second set your min command to 1000 and max command to 2000.
Then set up your min throttle(ensure that it is slightly above your ppm min value of your escs until the motors spin smoothly). Make sure that you click save.
Next I would look at my modes through the modes tab and make you have assign the right aux channels of your tx to create an arm switch, for my set up I also had blackbox and beeper function but its really up to you depending on how many switches you have.
Please feel free to send me a video of what happens when you arm it out of betaflight( when you arm it the motors should spin up to the min throttle that you have hopefully configured correctly).Finally check that you have the correct channel mapping for my taranis qx7 i have mine set up to AETR but for your tx it might be different.

#33

image

One of the version of Betaflight disables the ability your arm your quad while its connected to you PC.
Its a safety feature.
If you can run your motors from the motor tab and the stick commands are showing on the Rx Tab. Then thats a good sign.


#34

I also suggested to adjust his throttle endpoint to a min of 1000 (prevents deadband) wouldn’t you agree?.


#35

Alright, so unfortunatley nothing changed, still not working, I passed over all of the things you sent Mark and everything is set like they show.
The only differences I noticed between me to them is:
-there is no voltage in battery when im connected to the beta flight.
-there is no respond in the aux channel which I configured to be my arm switch, I tried also aux2 with no change and ofcourse no respond from the reciever.
I’m frusturated, do you think maybe one of the components has a fault? if so which one?
By the way DoomedFPV, the arming you saw its when I click on “I do understand the risks” at the motors tab.
Waiting for your response guys,
Thanks.


#36

Check your email I have sent you a video, I really hope this fixes your quad


#37

Okay, I made a big mistake changed the UART and rebooted and now I need to reflash the frimware, is it possible to use an old backup or something?
Except that I know for sure that there is a problem with my soldering in the battery or I forgot to solder something, becuase I dont see and v when the drone is connected to the PC and also when it connected to the PC and battery, I tried earlier to mess with the configuration of the reciever PPM output or Serial Based and then iBus( like Stu did in the vid) none of them worked,i’ll try to figure it out after this problem I did.


#38

Why do you need to reflash? im confused


#39

Becuase I changed the UART1 to UART3 and saved and reboot, so I lost my connection to the drone and its not possible to access it.
Such a dumb mistake.


#40

There should be only two cables soldered to the battery connectors? one black and one red right? or there should be more cables connected to it?