Diatone Crusader wont arm (low voltage flashing?)

multirotor

#1

Hi All,

I’ve enjoyed my Crusader GT2 for over a year and it’s been a tank till it was involved on a moderate crash last weekend. Issue is that it wont arm (on a switch) since and flashes “LOW VOLTAGE” reading 0 volts on the OSD with a fresh battery. Running Bata flight, Teranas 9x w/Frsky control, 4s bats. The receive light turns green when firing up the Tx indicating healthy up-link. I’m somewhat experienced but this one is beating me so far. One thing I did notice was that 2 of the plastic screws that hold the board stack in place had sheered off so I’m guessing that saw some impact G’s.

Any help is much appreciated

Ideas?


#2

Hey John,

This sounds like if your VBAT Connection has come lose…
Maybe double check if all cables are still attached.
If not resolder them or if you arent sure upload a few pictures. Maybe we know what to do.
Or just upload some pictures anyway :smile:

Luca :slight_smile:


#3

Thanks Luca - most helpful it all looked good but I’ll do some testing tonight and send some pics tomorrow.


#4

I was going to say… Have you tried charging your lipos… (I’m sorry)

Its does sound like your FC is damaged and its not reading the correct voltage but its getting the correct voltage as the rest of your hardware works.

Betaflight is detecting a low voltage and stopping your from arming.
There must be a way to shut it off.


#5

Check you settings… or try turning off VBAT

image


#6

Thanks All,

VBat connector swapped out with a spare - no love. Lipos are reading 16.8v. Interestingly, I cannot get it to connect with betaflight. Another bad board indicator perhaps?. It registers the right COM but wont connect fully. Any pointers on checking the steps there could be handy. If a new board, what’s the latest and greatest for this machine?


#7

not connecting to BF could be a sign of a bad board.

You could try and connect the board to your computer and then run the driver fixer tool and see if that helps.

ImpulseRC Driver Fixer


#8

Great thank you - I’ll give that SW a shot tonight. Cable talks to my other quads (Kiss FCs) so that’s OK. I went ahead and ordered another board (Dlink-F3) for delivery this week. Looks like it plugs in with the same ports as the original so that’s handy. Fingers crossed it’s not too finicky to tune etc. Anyone upgraded yet? I love whiling away winter hours on setups but in the summertime; I…just want to fly. : )


#9

Right - so close but alas. Tried to download the ImpulseRC fixer SW but my PC (Win 10 from work) said it had a virus. Tried to grab it from several other sites but got a download error. Could be the job’s got this PC shackled up some. Anyhoo…I’ll just put a new board in and share how that goes. Thanks again all,

J


#10

“Good news everybody”…New F3 board came in, connected to Betaflight, and everything fired up nicely. Scaled the PID’s back a little and all’s well till the next crash. New rev. board has vibration isolators but otherwise I could not tell the difference. All OSD functions fired right up without any additional fiddling. Happy days and thanks again LUCA and DOOMEDFPV for your help. PS - the job’s IT guys called me about downloading driver SW on a company machine. :blush: So likely a firewall thing.


#11

Happy flying…

Anything else you know where to find us