Why dosent my FC work?


#1

I just got my first quad a Diatone Tyrant S and i plugged in my battery and everything worked next time i plug it in the fc dosent power up it only works when i plug in a usb… im new to this and have no idea what to do please help


#2

Have you recharged your LiPo battery after your first flight?
Cheers
Steve :slight_smile:


#3

yeah i havent started flying yet it worked the first time then like an hour later it dident work anymore do i have to do something with betaflight? :slight_smile:


#4

Do you see any led when you connect via your battery only? If not then you might of fried your board somehow, if you ordered from us then we will arrange to replace the FC for you. You will just need to send a few photos so we can authorize a replacement for you.

If you do have Lee’s via battery power, then we can look into other possibilities. Did you try to update firmware at all?


#5

yes i get leds but not from the FC and no i havent updated anything how do you do that?


#6

If you don’t get any LED on your FC with the battery connected then Italy likely a regulator that has failed, could you send a pic of how it’s all connected just to be sure. Also if you did order from us you will need to send a support email so we can arrange a repair/replacement for you.

Don’t worry about updating firmware unless you know what you are doing as it will reset all.the board settings to default.


#7

yeah i got it from you heres a pic


#8

Thanks for the pic, from the looks of it your vtx is also not working but is that just the photo? Because if that is the case then something really bad happend?

Can you confirm its just the FC that is the problem as then i think it’s best for us to send you a new one, we should be getting dlinl f3 v3 boards in about a week or so.


#9

i think its just the FC… the fpv camera works if thats what your asking and i did send a support email before and never got a answear so what should i do? :slight_smile:


#10

oh nevermind just tried the camera and the vtx is not working to i guess :confused: