Diatone GT-M5; the saga continues - motors going the wrong way/vtx not working


#1

Firstly thanks to Luca and DoomedFPV for the help in getting me up to speed in soldering. The replacement Fury F3S FC arrived yesterday and today it got soldered with only one small problem; connected the battery connectors the wrong way. CRACKLE! Using new found unsoldering skilsl, I resoldered them the right way round, and checked all the other wiring; everything was correctly soldered.

Turns on; beeps in the usual manner (sigh of relief)
Connects to betaflight configurator and downloads the last good config. Transmitter connects ok!
Arms the motors to check that they’re rotating the correct direction - NO! WTF!!!
Double check the wiring; all correct!

Any suggestions besides swapping the wires round? I don’t really want to do this as Diatone in their infinite wisdom have cut the cables so close to the motor that the only thing I could do would be to add some extensions.

Also the vTX doesn’t work even though it’s plugged in as per original setting. (It wasn’t plugged in when I had the battery terminals the wrong way round)

Are all FPV quad builds this bad, or is just that the Diatone GT-M5 is cursed?


#2

the motors is an easy fix and you don’t need to move any wires

use blheli suite to change the direction of your motors.
The video below will help.

VTX does it have any lights on when the lipo is plugged in?
How is it powered?
Just wondering if that crackling your heard was a regulator dying.


#3

BH_Heli worked fine in reversing the direction. However the quad won’t arm either coming up with a sequence of beeps when doing the arming sequence.

#neverbuyingDiatoneagain!


#4

Saga ended - this piece of crud is going in the spare parts pile. EMAX Hawk 5 bought instead. Hopefully this one won’t be cursed like the GT-M5!


#5

You wont be able to arm your quad when your connected to betaflight its a safety feature.

Try unplugging the usb cable and trying again… with your props off


#6

Did that DoomedFPV; same issue.


#7

what motor protocol you using?
You may need to calibrate your esc’s and check your min throttle.


#8

It was D1200, but since my last message, there was a lovely burning smell that kept getting worse. The FC kept rebooting whilst connected to Betaflight. Tried re-flashing; nope - now bricked.
Bought another FC - third time lucky! :wink:


#9

arhhhhh…

Then soldering the lipo connectors backwards and power up… problemly did kill something. :frowning:

Its ok we all make mistakes. just look at my last post on the longrange build guilde

I just finished fixing it by soldering to the bottom pad and it all works… So i didn’t need that new FC.

We learn from are mistakes.


#10

Long range build is looking good! Glad to see I’m not the only one making mistakes :wink:
Oh well I’ve got a new quad out of this learning process. Maybe this GT-M5 will make it airborne one day as well :slight_smile:


#11

Oddly, yes you can arm while connected to Betaflight. I did this last night as i was setting up an F3 to test (with props off :wink: ). I was able to throttle up too.


#12

Are you using an old version of Betaflight?


#13

Standalone Betaflight Configurator 10.3.1