Desperately seeking help setting up new Wizzard x220S


#1

Hi all, really hope someone can help…

Bought my son a RTF wizard x220 last year - loved it and had lots of fun with it… after several months of use the drone was accidently flown into a seawater loch… I managed to recover the drone and whilst it half worked I have decided to upgrade to a X220S

My thoughts were that I would be able to use the Flysky FS-i6 controller and the hopefully the Fs-iA6b receiver from the old X220 with the new X220S drone… as even though it got dunked the receiver still seemed to receive fine after drying out…

have connected the old receiver to the new drone… but whilst I am getting a RX signal showing on the controller and a solid red light on the receiver I am not getting anything else… I do not seem to be able to arm the drone or get any movement on betaflight on the receiver tab…

I have been able to test the motors via betaflight and all seems well… just cant use the controller!!!

Please help…???


#2

Hey Jon,

Did you set your FC to PPM ?
Did you connected your Receiver to your FC properly?
Just double check all your configurations in terms of RX and TX.
Maybe swap out your Receiver…
Saltwater is probably one of the most deadliest things for electronics :smile:

Luca :slight_smile:


#3

Hey Luca

Appreciate the response.

Yes FC in Betaflight, config, Receiver, is set to : PPM RX input.
Checked Controller is set to PPM and it is.
Looked at connections and checked against circuit board diagram and they are correct.
Receiver LED is solid red as soon as I switch controller on. I am connecting the battery.
Ports in Betaflight look right from what I can see : Uart 6 Serial RX
Yes I am wondering about the water issue, but before I pulled the receiver out of the old 220 it was receiving fine, so I really don’t think this is the problem…
I imagine this is not possible, but I would love to chat this through on the phone if you could spare me 5 mins?? Totally understand if that’s a no…
Question ? even without arming should I see the bars move around in receiver in Beatflight when I move the controller sticks?

Thanks again for your suggestions… it can seem pretty lonely and futile when you spend 6 hours on it and don’t get anywhere, although I am learning a lot!!


#4


#5


#6


#7

image

Is that a solder bridge?


#8

Hmm,
Sounds normal for me…
I think it is possible to chat the hole thing through on phone but due to the fact that i am German,
it may not be the best Idea :smiley: (German = bad english (Mother nature wanted it like that :smile: ))
Maybe @DoomedFPV s point will help.
It looks a bit like LED’s or a solder bridge… Also check that out.
Since SBUS is nowdays more common than PPM i would solder it for PPM (IF it is an solder bridge)

Luca :slight_smile:


#9

@Gingerpride I tend to agree that you should have a look at the solder jumpers on the omnibus flight controller as @DoomedFPV suggested.

The other option is to buy yourself an Flysky A8S receiver (they are under $10) as this is the one included with the RTF wizard X220S, and then you dont need to worry about solder jumpers as the stock wizard flght controller is configured for SBUS receivers


#10

Thank you guys - really appreciate your help. Will do some investigating and testing and report back.


#11

Guys - does this give anymore clues??


#12

Apologies - the previous diagram was the wrong version - this is correct

Omnibus F4 V3


#13

Your solder bridge is wrong.
Un solder the center pad from SBUS and solder it to PPM.


#14

That makes sense… now you say it! - Great - will give it a go - thank you!


#15

Hate soldering… so nervous that I will damage the board… unfortunately it didn’t work… don’t know if it’s my terrible soldering or something else… is UART 6 correct?


#16

Give this a go

Using PPM

If you have trouble geting the FC to recognise your PPM receiver, here is what you need to do. You need to enable RX_serial in the GUI and turn UART3 on. Save and reboot the flight controller. Then re-selecting RX_PPM again on the GUY and the FC now communicates with your PPM receiver


#17

Uploading… Uploading… Uploading… Uploading…
sorry -don’t really understand the UARTs… how do I know if it should be UART 3 or 6?


#18

No joy… :frowning:
Going to have to leave it for tonight as its getting very late. Thanks for the suggestions. If anyone has any other inspiration please post…

Cheers & night.


#19

Just a note… if anyone is near Colchester UK and thinks they would be able to sort this for me I would be happy to pay for their time.


#20

Give this a go…

Connect to BF and under Ports and untick UART 6 - Serial RX … Then Save and reboot.
Then
Connect back to BF and under configuration and select PPM in the Receiver drop down… Then save and reboot.

Give that a go and let us know how you get on…