Wizard X220 not responding to flysky fsi6 inputs! HELP before i go insane!


#1

Hi. I know its long winded but its just to tell you where im at with the situation.

Ok so ive had my Wizard x220 for a few months now (set up properly with the many guides available) and had 6 successful flights until a few weeks ago when i crashed and broke my VTX at the threaded joint.At first i thought the antenna had just come undone and screwed it back on and tried another flight until i lost video feed and took another look.

So i needed a new vtx and i found a better one than the stock vtx with digital channel display so while i was at it i decided to buy a runcam swift 2. So everything arrived and i got to work fitting all the new parts including doing the Vbat monitoring and adding a buzzer.
With everything installed i connected to betaflight and connected a battery to make sure vbat worked etc and i was going to assign a switch for the buzzer.
The wizard did the usual start up and this time the buzzer gave off a beep but stopped and sounded like it died. when looking closer i had wired the buzzer back to front by accident and also i accidently flowed the + on the pdb when doing the vbat and it was kinda close to the + for the esc on motor 1. Noob errors i know !
So i unsoldered the buzzer and removed the solder on the pdb and resoldered and started up again with a battery connected. Everything seemed ok but my inputs on the reciever tab in betaflight were not being registered. After unpluging and pluging in the battery and messing around i then also lost power to the RX (Fs-ia6b).
This left me wondering if i had messed up the FC and/or the RX so i bought both and installed a new identical FC (SPR F3) and RX
Once again i connected up to betaflight and i flashed the FC and set up the same way as when i got my wizard but still none of the reciever tabs would move when i moved the sticks. I reset the FSI6 with factory settings and re-bound the rx and tx and set it up again like in the beginning making sure PPM output was set to ON in the setting and that failsafes were set to on etc. Double checked betaflight for the settings and PPM was on but still i was getting no movement on the reciever bars, not even any flickers !

The only thing i had noticed now when i started up the wizard via battery was that i heard all the beeps that i heard before but the motor on motor 1 was not twitching on start up. When i went into betaflight onto the motors tab i could spin each motor independently using the sliders and using the master slider and even calibrated the esc’s again !
This did not solve anything so i bought a replacement V2 esc to match the current one and a new identical motor.
Replaced the esc but left the motor becasue there doesnt seem to be a problem with it. Started up and now the motor twitches like normal, but im still not getting any input from the flysky TX on the reciever menu even though it binds everytime like normal !!!

I now dont know where to go with it because ive ran out of ideas and pulling my hair out!
What could be causing this other than a faulty TX ? Although ithe TX works when i plug in via usb to play DRL sim etc.
Ive not reflashed the TX yet and also ive not tried to set up the RX in any other way because i wanted to use PPM like it was before !

The problem occured after solering the buzzer backwards and maybe touching joints on the pdb but after fixing these i still have the same problem ! Ive not tested voltaged with a multimeter from the pdb to fc because im unsure what im looking for etc.
If anyone can help then that would be awesome .
Thanks !


#2

PROBLEM FIXED ! :smile:

So i read a post on here about trying the rx connector in the other port on the other side of the FC because they are sometimes back to front and hey presto i now have the reciever tabs moving !
so im now plugged into the port behind the camera but im sure that before when i got the wizard it was plugged into the port next to the buzzer ?!?
Anyway hopefully problem solved and i can get flying again !