Help with my Noob Wizard X220

Hey everyone. First post here.

Here’s the situation. Picked up the Wizard X220 to get into filming FPV for my video production company. I set it all up and everything went well. Upgraded the firmware on Betaflight and had a first great session getting used to flying. Near the end, I had a small crash and now my Flysky FS-i6 wont bind to the FS-ia6B reciever. All the lights still work on VTX and receiver and the LED flashes on the FS-iA6b like normal to show that it’s ready to be bound. No physical damage on the receiver or anything that I can see.

Since I did it the first time, I’m confident that I’m doing everything right but no cigar. I’ve tried plugging in and out the binding cable 100 times and still no luck. I’ve tried setting the controller to AFHDS 2A on and off. Same with PPM output. Been through lots of youtube tutorials and what not.

What’s the easiest way to diagnose what is causing me the issue so I can replace the part? Are there any LEDs on the board that light up that tell me what’s wrong exactly? I’m super confused on what to do next. I’ve went and bought a Frsky Xm+ and Taranis QX7 and TX526 transmitter but it will require some soldering and I’m waiting on my solder kit and quite amateur in that regard.

Any help or alternative methods for helping me bind are much appreciated.

Thank you!


Hook it up to Betaflight Configurator, see if you get stick movement on the “Reciever” tab. If not, the SBUS from rx to fc is most likely broken, or the rx itself is bust.