Wizard x220s crashed, motor not working

wizardx220
eachine
multirotor

#1

I have problem with my wizard x220s ,after small crash one motor stop working.I checked it and no current was coming from esc to motor and in Betaflight and in Blheli configurations only 3 of 4 in 1 was showing up so I replaced 4in1 esc unit and to my surprise still no current to the same motor.Whare is the problem?
Marti


#2

The current to a motor from the ESC is AC and not DC so you may have had your voltage set wrong on your mutlimeter.

Does BLheli know detect all 4 ESCs correctly?

Are the motor winding’s black or look burnt ( if so you have a dead motor, which could short out your ESC killing that too. )


#3

I checked it with new motor and checked old motor too


#4

does the dead motor beep when plugged in (hold it to confirm) are you sure signal wires from FC ok. to check swap dead motor wire with one that works!
do that then get back with results, very hard to diagnose fault without quad in front of you.


#5

was only a pic anyway but a lot clearer than the one above, wrong thread


#6

If you tested a new motor and a new ESC, and the same ESC is still not working then that would suggest to me that its the output on your FC that is not working?