Motor 2 stopped working after blHeli config

wizardx220

#1

gday folks! I’ve got myself in a mess with my second wizard x220 (first crashed and caught fire!).
I bought an ARF to bind to my remaining fs-i6 radio- got it all up and running using joshua bardells video on beta flight set up. the issue was it had lost a significant amount of “punchiness” or motor rpm. I have been over both my radio and betaflight setup and cant find the issue at all (so that is intact my first problem). secondly I tried to re flash esc’s on BLHeli just incase there was an esc problem. to was successful in flash on a few attempts but on a final attempt I tried “defaults” which rest my throttle ranger (I think), now motor 2 dose not work! I’m at a loss, hopefully someone knows how to sort this one.


#2

new development: motor 1 esc just short circuited on my lap…:thinking::weary::face_with_symbols_over_mouth:


#3

Not good, but definitely sounds like youe motors/ESC are dead… well definitely now anyway!


#4

lol, yeah.I just wish i could understand why, after all my checks and work on the drone it never had any punch. I recon the esc overloaded running a blheli programme beyond it capability (thats what was what was suggested by some i knows who knows a lot more about this than me). its all learning but id prefer to learn to fly!) (better)