Installed ESC on Wizard 220 but not spinning up when armed

multirotor

#1

Hi All,

I recently crashed and burnt out my first ESC but now the motor will not spin up when armed like the rest. The drone flies ok but when I have zero throttles that motor stops and the rest continue to spin because they are armed and try to keep the drone stable during power loops etc.

The Video link below is my drone arming and hovering.

Video Link: https://drive.google.com/open?id=11f7ZwcRBY0EXIQ_dA6-LWE_sCXZ2tPqb

  • Burnt out ESC was a “Eachine efm8bb-20a-s4-v1.2”

  • Replaced with a “RacerStar BLHeli_S 20A V1 ESC”

Tried to use BLHeliSuite to check ESC but couldn’t get it to work. The program could see the ESC but reported them has unknown, which was a pain.

Any help would be good?

Many Thanks, Nathan


#2

don’t forget when using BLHeli your need a lipo plugged in… (props off)

Looking at your video… maybe you ESCs just need calibrating.


#3

It will need recalibrating since you have effectively swapped it for a different one and the values will be different (as will the protocol if it’s not using the same)


#4

I have just tried to connect to the ESCs with BLHeli but getting the below error messages:

BLheli%20errors

Then it tries to flash the memory in each ESC #1, #2, #3 & #4 see below:

Flash%20Memory%20ESC

Memory Flash fails so it tries to erase the ESC completely.

Erase%20Completely%20ESC

But it fails:

Erase%20Failed%20ESC

What do I need to do???


#5

Not sure whats going on…

There wasn’t a lot of information online that I could fine.

Try flashing the ESC’s one at a time.
Your only need to disconnect the signal wires.


#6

The issue was with the program I was using and not the ESC or anything else.

I was using the BLHeli32 Suite, I found another BLHeli program which plugged into Chrome and this worked great.

I plugged in my drone and the program picked up the ESCs without a problem and I manage to update the firmware on all of the ESC. One of the ESC needs adjustment to bring it RPM setting in line with the rest of the ESC which I believe was the new one. Carried out a test flight all ok.

The motor spins up when armed, hovers and fly great again.

NastyPastyX


#7

Glad that you found the issue… it seems that alot of people have this issue as it’s not particularly clear that there are two versions of the software… it would also be nice if they can add the warning message to say check if you are using blheli32suite with 32bit ESC, and blheli_s suite with blheli s ESC.


#8

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.