Wizard x220 and Flysky FS-I6

fpv

#1

I just got this drone from banggood and was able to set it up with the help of a guide I found online.

Only issue is that when I fly it my motor 3 doesn’t spin up fast enough to make the whole drone fly. I then hooked it up to betaflight and saw that my 1,2,4 motors were fine except 3 when I controlled it with the Flysky with props on.

I then tried it just doing the motor control through betaflight and all 4 motors spun up perfectly fine. Not sure what setting I need to enable or disable with this.


#2

Try using blheli to calibrate your ESCs

But just for safety of your fingers please remove your props while testing. ( if you haven’t already done so)


#3

I just hold the top down on the battery when testing it out, so I am not chopping any fingers off.

I will try blheli to calibrate


#4

I tried to connect my Escs to this and it said that it is not supported.

I also tried the betaflight configuration with the guide you gave and it still didn’t change :confused:


#5

You don’t necessarily need to connect to your ESC to calibrate them, you just send a high throttle value when powering them as per the guide linkee above :slight_smile:


#6

Hi cat_skratch

I have the same setup as yourself.

I bought my Wizard over a year ago and have had two issue with it only.

  1. 6 months in I had a faulty motor; The drone would hover for a few seconds then one motor would cut out or slow down CRASH! Had to replace the motor, no problems, all ok.

  2. Recently I burnt out an ESC which I had to replace but had a problem when arming the drone the new ESC wouldn’t arm the motor, so I can to adjust with Bheli.

I had the same problem you are having with the Bheli not reading the ESCs. On another forum, I was informed I was using the wrong Bheli program. Once I switch to the correct program I could update the firmware and adjust the max and min RPM without an issue.

So, check which application you are using blheli32suite with 32bit ESC, and blheli_s suite with blheli s ESC. I needed the blheli_s which I found as a plug-in for Chrome.

Search in Google - “Bheli Configurator”