FPV Quad motors spinning both ways

blheli
esc

#1

Hi guys. I’ve recently ordered and almost finished the Emax 170 kit. It’s a great little quad with quality components.

However I’ve been encountering problems with one of the nano 20A escs. Three escs calibrate as expected with no problem but the fourth won’t calibrate. I’ve tried running cleanflight with oneshot enabled and all motors spin but are uncontrollable. With oneshot disabled only three motors spin.

Sometimes I get a continuous beepng noise from the esc when the motor remains still. On a couple of occasions I have calibrated the escs and the problematic esc runs the motor at full speed at zero throttle and as I centre the throttle the motor stops and then turns in the opposite direction as the throttle increases.

I’ve read that this could be due to an acro mode? If it is why are the other escs behaving as expected? I’ve built several quads and have never come across this problem before. Thanks for any help or advice you can offer


#2

Could you chek to see if hte motor is switching directions when you go above neutral and below? If that is the case then somehow the ESC has been set to 3D mode. Also I assume you have tried to run the ESC calibration again to double check that is not the fault?

As for the ESC config, you will need to use a USB linker device that lets you connect them to your PC to change the settings. If you would like to get one from us just let me know and I will check which one of ours are compatible with the Emax nano ESC’s


#3

The motors are definitely switching direction at neutral throttle. I have also tried esc calibration in cleanflight and using the transmitter.

It would be helpful if you could recommend a usb linker device for the escs please.


#4

The emax nano are all BLheli, but right we do not sell the emax bl heli program card anymore, but you can program it via your RC tranmitter following the guide here. It might be easier to program the ESC by connecting them directly to your receiver, or by using a servo tester. The menu you need to change is D8 to change the direction back to normal instead of bidirectional.


#5

Hi
What flight controller are you using?
You may be able to connect to the ESC’s via that using Cleanflight or Betaflight instead of a USB Linker
Might be worth a try :smile:
Cheers
Steve :slight_smile:


#6

Correct, that is better if you are using BLheli_S ESC, I just finished a BLheli ESC guide explaining all of that too if anyone want to know more about it.