X220s problems with flight controller


#1

Hi all im new to flying and im having real trouble with the soldering/setting up.
I’ve had problems with the flight controller so i bought a new one and have tried to wire it in myself. I havent wired in the reciever or the cam yet and im getting a strange beeping coming form each motor. The motor in top right twithces like rest the moment i plug the battery in but then does nothing whilst the other 3 motors continue to twich and beep and differnt speeds and interval. Sorry i cant explain in more detail. I have a taken a video it happening. Is this something i should be concerned about or should i continue to wire in the reciever and cam. Im a bit stuck.
Here is a link that i Hope can help

Thanks in advance


#2

I had the same problem on my setup…
Try to recalibrate all of your Escs and make sure they are in Sync.
You can do that via BlHeli Suite

Tell us how you get on :slight_smile:


#3

Hi Luca thanks for getting back to me. I just needwd to watch a video on it first. I’ll try this now. I’ll post with how it went once its done.
Thank you


#4

I’m not getting anything in blheli. When I plug it in it gives me a warning about props and to connect the power to the esc i get 3 beeps but nothing happens in blheli.
I followed a tutorial on youtube using beta flight to configure the esc but it didn’t have any effect. Im not sure what else to try


#5

Now i have the same problem as the first flight controller. no led are coming on the fc when plugged into either the usb/lipo or both. I’m doing something massively wrong and i can’t work our what it is. Betaflight now says failed to open serial port. And the original problem seems imposible for me to solve. Has Anyone had simular problems to this before and found a solution?


#6

try using a different usb, rebooting your computer can sometimes help.

Also when the FC is plugged in and still not working trying installing the driver fixer tool as see if that helps.


#7

Thank you ill try that although it stopped working when i lifted up the fc to high and pos power wire came lose from the 4in1 esc. Could that have fried it somehow. Im new to all of this so i lm not sure.i will try this download in the morning when im at the pc. Thank you so much for this help
(:


#8

If you are not getting any led on your flight controller at all then maybe it is damaged. Do you get any led when you plug the battery into your quadcopter?

I also know you usually need to have battery connected to configure your blheli ESC via passthrough mode . I assume you are using the blheli suite software to check ESC settings? We have a guide here:


#9

Hi Alex yes I’ve tried both suggestions but neither are working. Blheli wouldn’t even recognise it even when the fc leds was still lighting up. I’ve somehow fried 2 boards in 1 week. May i please drop it in for repair. I feel it would be better to have the work done than end up with an even bigger pile of broken flight controllers. I am driving through milton keynes today. So it would be easy for me to drop it off
Thank you


#10

Hi
This won’t solve your current problems :anguished:
But if the beeping from the motors you mentioned in your first post started about 5 minutes after powering up but did not run the motors then what you are probably hearing is normal, it’s the ‘beacon’ feature within the BLHeli ESC software, it’s a crude 'lost model alarm’
It can be annoying though, especially when setting up a quad which can take an hour or so.
I use the configurator software motor test to give them a quick low power run which shuts them up for a bit
If you are familiar with BLHeli suite software you can configure the volume and time delay which is useful
HTH
Cheers
Steve :slight_smile:


#11

Hi Steve thanks for responding. Does it make a difference if it was starting the moment i plugged in the lipo?
I couldn’t get blheli suite or configurator to read the quad. But id never used them before yesterday so its more than likely user error.
I have sent it in to be repaired now as i couldn’t quite get the hang of the soldering to those small pins. The more soldering i have done the more of the quad that gets broken. I’m hoping the next time after this that something goes wrong I’ll be able to do it myself.


#12

Hi Matt @Guan
Hmm… if it started straight away when lipo connected, it won’t be the ESC 'beacon’
I’ve just checked my history and the default time is usually 10 minutes so it seems like it was something else.
Hope it all works good when you get it back and happy flying :grin:
Cheers
Steve :slight_smile:


#13

Thanks Steve.
I’m really looking forward to it. Way to much fun(:smile:


#14

Hi,
send us a video…
We’d love to see how you get on with it
Cheers
Steve :slight_smile:


#15

I will do. I’m curious as to how bad the problems are. Maybe im over egging it in my head or something. Ill post a video as soon as its returned. (:


#16

The weird beeping you are hearing is because the ESCs are telling you they do not have a valid control signal input, and you don’t have that because you do not have the receiver connected to the flight controller.

What you really need to do is stop every thing and read the wikis for the flight controller firmware you are using, read the manuals for the flight controller, RC radio, and RC receiver and ESCs you are using, and then read the wikis for BLHeli firmware and BLHeli Suite. Follow the wikis and manuals STEP by STEP.

One other VERY IMPORTANT thing you need to do is EVERY time you start a thread asking for help, include a detailed list of what you are working with, ie., flight controller, firmware, ESCs, motors, RC radio, RC receiver, video transmitter, camera and so forth.

As a first step in EVERY BUILD, connect the flight controller to your computer and make sure it boots. Second, flash the FC with the latest version of your chosen firmware. Third, calibrate the accelerometers. Fourth, bind the receiver to the radio. Following these steps will basically prove the hardware is functional so you can continue on with the build.


#17

I’ll make sure to follow all this advise in the future and i really do appreciate it. I feel my egourness to fly has got in the way of any actual common sense.
I’ve sent it off to be fixed currently by a professional. But im certian I’ll need to learn this stuff the next time something breaks.

I’m using a eachine wizard x220s
Motors:mn2206 2300kv
Esc:30a blheli s 4in 1 esc
Camera: 800tvl
Transmitter: taranis qx7
Reciever: frsky r xsr
Flight controller: airbot omnibus f4 5.1