Vortex 250 spektrum lead voltage

vortex
spektrum

#1

Hi I’m new to vortex 250 quad.having read about the included spektrum lead elsewhere it says there is a processor in the lead for dropping it to 3.3v? I’m using a SPM 4648 race satellite, and the lead that fits is just a short normal one. Thanks
Mark


#2

To be honest I use Frsky instead of spektrum gear so I actualy have not used that cable :stuck_out_tongue: , but I do believe the spektrum cable outputs 3.3V. However if you have a multi-meter handy it might be a good idea to measure the voltage first as I see the SPM 4648 race satellite only supports 3.3V whereas other satellite receivers support a wider range of voltages. I dont have a vortex with me right now to check, but if you want me to just let me know and I will check tomorrow when I am back in the office :slight_smile: .


#3

Hi Alex. Firstly I’m very impressed with your service.
I would be most grateful if you could check for me when you can, as I don’t have any testing equipment
Regards Mark


#4

I have just checked the voltage (sorry about taking so long, but its been a busy morning!) and I can confirm teh spektrum outputs 3.3V so you can use your receiver with it :slight_smile:

Thanks for your kind words :slight_smile: thats what you can expect when you order form us as its only fair if you are paying us for something, and from time to time we might drop the ball but we do try make it up.


#5

Thank you very much for your help, and I will recommend you highly around the club’s.
Just got to wait for my lipo to arrive, then I can plug it in and see what happens :grinning:
Regards
Mark


#6

Hi Alex .
After being away for a few days my lipo finally arrived for my Vortex. It flys fantastic and was so easy to set up…bar one thing😯 I fly mode 2 and to get into the other set up screen for changing led lights and battery voltage it says throttle stick low and left then hold it. I can’t get into it from some reason, I maybe missing something stupid. Have tried lowering throttle trim, and connected it up many times but to no avail
Regards Mark


#7

Are you holding it there for a few seconds? Its kind of a strange one since you say it flies great so it cant be a radio issue? Do you know what firmware version you are running as I do recall a few older vortex 285 having a bug in the early versions which prevented you from getting into the OSD menu.


#8

Hi it’s a Vortex 250 and I’m not sure about the firmware. I only bought it last week


#9

Yes I hold it low throttle left, for ages many times but it won’t go in.
Mark


#10

Have tried looking on more forums.have tried moving end points and trim on rudder and throttle but still can’t enter the menu where you change settings. And also have re set the main osd settings at start up …any more ideas ? Can I do it from a pc ?
Mark


#11

Just a thought, have you trimmed yaw all the way to the right before trying to enter the menu?


#12

No not all the way… only a few clicks. I’ll try it in the morning


#13

Hi Alex. Have tried yaw trim all the way, both ways.
Never mentioned before but in the main screen when you first start it, there are lines of information like battery voltage and channel, the line with BLACK BOX is FLASHING every time. It says
(Black box 2.0 / 2.0) no other lines flash.
Mark