Use your Walkera QR X350 Pro with APM Mission Planner


#1

Did you know that the Walkera QR X350 Pro quadcopter actually uses a version of the arducopter firmware? That means that you can connect it to the mission planner to unlock all of the powerful features the arducopter firmware has to offer, like autonomous waypoint flights! I dont recommend upgrading to the latest arducopter firmware unless you know what you are doing. Otherwise its best to wait for walkera to release thier new firmware versions that have been configured specialy for the walkera X350 Pro flight controller.

Here is the video

And another tutorial on using the X350 Pro with the mission planner


QR X350 pro USB connnect problem
Walkera X350 Pro vs DJI Phantom 2
Walkera TALI H500
Help setting my tali h500 flight controller up
#2

I have been using mission planner for configurations and waypoint missions with my QR X350 Pro but never have been able to download the dataflash logs. Does anyone know if this is supported on this unit or not?


#3

The X350 Pro does not support onboard data logging as it does not have a dataflash built in. However if you add the telemetry kit to your quadcopter then you can store the telemetry logs on your PC/android device.


#4

Can someone help please. I have my QR X350 Pro now working with mission planner and reporting back with the 3D Telemetry V1 but it seems to take SO long to get a good GPS HDOP and Sat Count. I know they are there as I check with my GPS. But last night it took almost 45 minutes to get the motors to power up.

I am on the latest firmware but someone mentioned I should drop down on the firmware. So any help would be very much appriciated

Grandpa Jake


#5

Has anyone tried Mission Planner with the Walkera QR X800? I assume it would be similar or even have more support for APM, however assuming usually gets me into trouble.

Thanks!


#6

Sorry just signed up here so don’t know if I’m in the right place. I followed Justins youtube vids (first vid above) and used the same settings. Programmed a test waypoint run. Double checked etc but when I hit the Gear switch as suggested (channel 8). I tried in stabalize and loiter mode but nothing happened. Do I have to set something in Flight Modes if so how do I know where to put Auto. Thanks in advance


#7

You will need to change the flight mode settings via mission planner. Before you go and fly you can also check its all working as when you switch CH8 (if thats the one you setup) you should see the modes changing on mission planner when connected via USB.


#8

Thanks unmannedtech but in fact everything was actually working it seems that after you activate Auto it just takes a bit of time before it kicks in for anybody else using it for the first time